Sourcetree Access/Permission during installation

I'm still very new to Sourcetree and this is the first time I've really installed it on my own.

 

The issue is that I've granted access to something and I'd like to know more details on what I've done. A page popped up in my web-browser during the sourcetree setup. I was half asleep at the time and hit the accept button without thinking clearly. 

 

The page that popped up in my broswer had something "localhost" in the address bar and listed a bunch of things I needed to either "grant access to" or "give permissions" Something of that nature. I think I remember the button at the bottom say "Grant" like I said earlier, but it may have been something else.

 

I apologize for the vague details. I was very tired at the time. I tried recreating the process today and the page doesn't pop up. The most I get is "Authentication Succesful" from a similar address. The most I know is that Localhost has something to do with my actual machine.

 

If anyone can shed some like, that would be incredible.

 

Can anyone help me understand what I granted access/permission to? I wasn't doing anything else at the time, so I assume it has to do with sourcetree.

 

 

1 answer

0 vote

Hi Rob! During the installation process, SourceTree doesn't ask you to grant permissions to anything. When you install SourceTree we ask you to accept the Customer Agreement, which you can re-visit by clicking About SourceTree > Customer Agreement.

If you'd like to get more help with that, we'll need more information regarding what you were doing at that moment. Another option would be to wipe SourceTree preferences, uninstall it, install it again and see if you get the same pop ups. I've tried reproducing the steps and didn't get any pop up, asked some of my colleagues and it doesn't sound familiar to them either... let us know! 

Cheers,

Ana

Hey Ana, I highly appreciate your quick response. 

Unfortunately, the details I've given are the best that I can come up with. When speaking about it with a coworker we thought it may have had something to do with authenticating/connecting Sourcetree to Bitbucket. I thought it had something to do with the Oauth authentication.

I tried recreating it on another machine with a new account and on a new network, but nothing happened.

I did try wiping SourceTree preferences, but I'm still not sure. Thank you so much for all your help. I'll have to keep digging.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you