Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,807
Community Members
 
Community Events
176
Community Groups

SourceTreeForMac keeps asking me for github authentication

I am trying to list my available remote repositories to find one to clone.

I am prompted for my github password because:

  • I had to reset my login keychain
  • My github password was changed recently

When I attempt to refresh the list, I get an error: 

message: Requires authentication

Sometimes I get a small popup with username/password. I fill in the password (which I have verified is correct), and I still get the same error message.

Other times, I get a large dialog to allow SourceTreeForMac from Atlassian access to my github account. Again, I put in the same username and password.

I still get an error message saying that it failed; however, I also got an email implying that it succeeded.

One thing to note is that my list of accounts is using an ssh key, not a username/password (basic/ssh/default).

I recently switched all of my repositories from using https to ssh.

 

P.S. I realize that there are at least a few issues with similar (or identical) titles, but none seemed to be the same problem and/or there were no clear solutions.

1 answer

0 votes
Manju Atlassian Team Sep 05, 2018

Hi there,

Very sorry for the inconvenience caused by Sourcetree. Have you tried removing your github account and adding it back? 

Before you do so, please make sure you also remove any keychain items that might have been not cleaned up by Sourcetree. We see these issues sometimes when there is a problem accessing keychain or there are duplicates in the keychain which aren’t visible when inspected. Many a times, a restart of the Mac also has helped get around permissions in keychain. 

Should this not resolve the problem, please feel free to get back here and we’ll help you out.

I tried removing my github account and then re-adding it.

I also removed my github password from my keychain, and then tried removing/re-adding my github account in sourcetree.

I am still unable to view my repositories in the remote repository browser.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events