SourceTree often becomes unresponsive when I try to commit

About 25% of the time when I try to commit, SourceTree hangs.  It seems like it is just processing, but it never finishes even if I leave it a long time.  Killing it from Process Explorer and committing again has always worked;  I just have to type the commit message again.

Using SourceTree 1.9.6.1 on Windows 10.  Working copy is on my local drive, but it is set to use a Git repo on a mapped network drive (SMB, I think) which is set to be always available offline (so it is mirrored by Windows on my local drive).  I also consistently push changes to BitBucket.  I haven't yet tried committing without pushing to see if that helps.  

The SourceTree log file shows only one kind of error, but it shows up a lot (about 100 times already today).  I don't know for sure if it happens around the time that it hangs or not:

ERROR [2016-08-29 07:47:42,956] [34] [System.IO.FileSystemWatcher] [OnError] - RepoWatcher: Error 'Too many changes at once in directory:S:\System Control Schematic and PCB.'
ERROR [2016-08-29 07:51:07,081] [34] [System.IO.FileSystemWatcher] [OnError] - RepoWatcher: Error 'Too many changes at once in directory:S:\System Control Software\SystemControlOnJumbo\SystemControl.'

I just noticed that the paths in those error messages are not used for the commit I am trying to do;  the working copy is on C: and the Git repo is in S:\System Control Software\SystemControlGitRepo.  I do have SourceTree bookmarks for projects in the two directories that cause the error messages but I am not viewing those projects in SourceTree when it hangs, so it shouldn't need to try to update them.  If I do view those projects in SourceTree, they seem to display fine (it takes a few seconds, but not very long - they don't have many files).  

I don't really have a question, as restarting SourceTree and trying again isn't too much of a inconvenience, but I thought I might as well report the issue.  I would be glad to run other tests if it would help identify the root cause of the problem.

Steve

2 answers

This widget could not be displayed.

I don't know if my issue is related to these reports or not:

I don't think it is related to https://jira.atlassian.com/browse/SRCTREEWIN-5326, that crash happens when they try to enter the commit message.  My happens after I enter the message, when I click the "Commit" button.

Steve

P.S.  I wasn't sure if I should create an issue for this or not.  I would be glad to if that is the best way to handle this kind of thing.

This widget could not be displayed.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

879 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you