SourceTree keeps asking me "log in to your atlassian account"

I installed SourceTree on mac.

When I run it for the first time, a wizard was out and showed me some licenses, which I accepted. (And I refused to send user data to Atlassian.) Then another step of the wizard popped out which was "log in to your Atlassian account". There were two buttons below but neither of them could bring me to the next step. One is "Use an existing account" and the other is "Go To My Atlassian".

Clicking on the first one will pop up my altassian account setting page but I can only save the settings there, while the second one will just open another web browser window.  

So I was stuck in this step of the wizard. Any ideas? 

 

Thank you very much in advance, 

Shane

17 answers

I've managed to get it working for me now. I moved SourceTree to the trash can, manually downloaded the latest from the website (2.4 from sourcetreeapp.com) and moved it to Applications. Run it from there, confirmed the usual security question, and this time it whizzed past the login page after a couple of seconds to the normal repo list. It seems to have kept all my old settings, so that's good. I'm guessing there's a problem with the auto-update.

Great David, thanks, using your method finally did the trick for me smile Thanks a ton, have a nice year ahead!

I also had this issue and the only way I found around it was to download an older version of it and install it, once it installed it updated itself past this new feature.  (This was on my Mac).  Hope that helps someone else

Try changing your default browser to Safari. I was on Chrome and had the same issue. Changed to Safari and registration process worked.

Hi, unfortunately, this didn't work for me. I even rebooted my Mac after setting Safari as default browser, nothing helped. For me only David's method worked. Thanks anyway, may help others.

I had the same issue and this worked for me. Thanks! What a nasty bug, and apparently very old one, they should have it as a P1 an fix it immediately!

I'm having the same issue. Can't get passed the 'Atlassian Account' step, even though I logged in successfully

Same issue here, with OsX. Wizard stuck at 'Atlasssian Account' stage.

"Use an existing account" brings up a log in page in a popup window, I can log in which takes me to a  "Manage your account" page and I can't seem to do anything else useful from there.

Clicking "Go To My Atlasssian" opens up a browser, again I can log in successfully and I'm taken to a page of Licenses with a "SourceTree: Free License". I can download the license file but contrary to the instructions there is no "SourceTree > Registration" option even if you could get past the wizard. 

Seriously? Was this tested at all before deployment?


There was a problem with the id.atlassian.com page back in April that broke this process for everyone. If you are having problems now, it isn't the same thing, because they fixed the page within a day of it being reported.

There may, however, be a NEW problem with id.atlassian.com that is causing the same symptoms. If this is the case, expect to see lots of reports from users.

If it seems to be happening to just you, you might check to see if some proxy, firewall, OS setting, or browser setting (looking at you IE) is interfering with the SourceTree installer loading id.atlassian.com

I'm also having the same issue.  It's now Aug 2016.  

Looks like I have the same problem

I have the exact same issue on Macbook pro "OS X El Capitan" 10.11.5   December 2 2016

Same for me sad

Same issue really really annoying!

Same issue. I'm also stuck after the update of SourceTree on Mac.

Same issue with my SourceTree on mac. Upgraded and stuck at "Log into your Atlassian Account"

Try changing your default browser to Safari. I was on Chrome and had the same issue. Changed to Safari and registration process worked.

Also, what a pain.

Same here. Sierra 10.12.2. Don't have Chrome, only Safari. Maybe it's doing some naughty networking stuff that my router is blocking? Anyone know what it's actually supposed to do? Is there a button missing?

I've just changed the display resolution, and it looks like there was a Cancel button off the bottom of the screen, but still no way of advancing.

I am also having this problem, it was a preinstalled source tree from a work mac, i cant install off the site without admin privileges, and i cant go to "About SourceTree" to check the version, but it should be a very recent version. So yeah not sure what to do, will have to wait till i can get an admin to sort this out i guess, but so much red tape at this company sigh.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

273 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot