SourceTree keep asking password [Windows 8.1]

I'm using sourcetree 1.6.18 and it keep asking password. I tried Removing and adding account in hosted repositories.But still it keep asking password every time even when i don't pull of push. Even though remember password is ticked it didn't save the password.

6 answers

Check if you have the right credentials saved in Tools\Options\Authentication . You probably have a wrong password stored here.

Hi

I'm having the same problem in Windows 10. Nothing I try will make the password save. I really want to use Sourcetree, but this is a deal-breaker

Thanks

Dan

I fixed this error after reinstalling sourcetree

Hi

I figured it out. I'd switched on 2FA and (naturally) Sourcetree can't log in. Until I figure that out, I've switched 2FA off

Hopefully this helps someone as forgetful as me!

Hi Dan, I'm not so clear about your answer. It means that you solved it by turning ON 2-factor authentication, turning it OFF would cause problem, do I get it correctly? Actually it should be considered a workaround: I'm doing so now, up until now so far so good, no more annoying pop-up asking for password every 15 minutes. But there's some trade-offs: - Turning on 2FA means that everything must be done through SSH. At first I avoided the mess with setting up the key, set SSH agent running etc, and I guess many people prefer HTTPS for the same reason. - No longer see the list of your repos via built-in menu (Ctrl + Shif + H or View > Show hosted repositories). SoureTree basically cannot sign in with 2FA turned on. (They're "still" busy with implementing app-specific password or token). Anyway, now I prefer SSH, as with HTTPS no matter how I tried (editing account, deleting account and add again, leave account fields blank, do git pull in git bash, edit in Options > Authentication, ...) it KEEPS asking for password, even in "idle" time (no pull, no push). Drives me nuts literally.

Still have the same problem on Windows 10. Checked the credentials, but still getting the popup after some time.

Same issue here, credentials are correct. Pop ups are endless.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

570 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you