SourceTree hangs on Atlassian login screen

I am using windows 7. I tried installing last 3 releases of source tree, one by one following the clean up methods suggested including all the folders clean up etc. But i never succeeded. It always hangs in the atlassian account login window. When i checked windows Application logs, it says faulting module is "jscript9.dll". The log is as shown below.

Faulting application name: SourceTree.exe, version: 2.1.11.0, time stamp: 0x598e3eeb
Faulting module name: jscript9.dll, version: 11.0.9600.16384, time stamp: 0x5215e4c5
Exception code: 0xc0000005
Fault offset: 0x000000000041aaac
Faulting process id: 0x49c
Faulting application start time: 0x01d32c7e96e8bae5
Faulting application path: C:\Users\kpaduvil\AppData\Local\SourceTree\app-2.1.11\SourceTree.exe
Faulting module path: C:\WINDOWS\System32\jscript9.dll
Report Id: c9f78798-9872-11e7-bf1a-5ce0c557b4f2

 

2 answers

1 accepted

This widget could not be displayed.

Hi Michael,

I was able to resolve the issue myself. Justs down graded my IE version from 11.0.XXX to 8.0.XXX and then did a clean up of previuos source tree installation and rebooted and reinstalled. Things worked well :).

I think the alternate could be a 'Windows Update' which I was not able to do since my admin blocked the same. So i downgraded the IE version alone.

Hope it might help someone else, so putting the solution here.

This widget could not be displayed.

Hi

Are you able to login to Atlassian account, https://id.atlassian.com, using Internet Explorer?

The WPF webview Sourcetree uses for the login process relies on IE and because its not used as much these days it sometimes is out of date, has configuration that prevents the login completing.

e.g. https://stackoverflow.com/questions/7674286/windows-7-64-bit-internet-explorer-9-crashappcrash-jscript9-dll

Hi Michael,

Thanks for your quick reply. You are correct, I am not able to login to the 'atlassian' through IE, but able to do in chrome. Through IE, when tried login it keeps crashing again in jscript9.dll. I just tried "regsvr32 jscript9.dll" command which was given in your link. But it is of no use :(. My IE version is 11.0.9600, so i dont think it is an older version. So what should I do to fix this problem? Any pointers please.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

722 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you