SourceTree fails to start new feature

Hi,

I have just updated SourceTree to V1.8.1.0 (System Git V2.7.0).  Now, when I go to Repository | Git Flow | Start New Feature, fill in a feature name based on the latest development branch, I get an error that says:

sh.exe C:\Users\Patrick\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start abc
Completed with errors, see above.

 

This worked fine before the update.  Any ideas?  (The message doesn't seem to say much.)

 

Kind wishes ~ Patrick

 

PS - Please can we have the Git Flow button back on the main menu, at least as an option?

5 answers

+1 I am getting the same thing. 

Same problem here.. not being able to start new feature branch after updating the source tree

Same issue, after updating to new version. Any fixes?

PS - Can you put Git Flow button back on the main menu ! 

 

+1 Also i am experiencing not able to start feature and button GIT Flow is gone. any idea when fix is available ?

 

Apparently, they are working on it.  Temporary fix is to drop back to a previous version. You can find a link on their Twitter feed @Sourcetree ( (Win), (Mac))

  • Patrick

PS - I found I had to do an uninstall of 1.8.1.0 before I tried to install the new one.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

834 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you