SourceTree fails to launch (9/20/2017)

Win 10 64.  I installed nothing.  Today when I click the ST icon, it shows an icon and returns to the desktop.

Uninstalled

Cleaned registry

Deleted Atlassian folder

Deleted SourceTree folder

Rebooted

Installed SourceTreeSetup-2.3.1.0

The install runs with no dialogs of any kind.  Icon pops up then goes away.  It appears in the Programs and Features window.

Repeat....

Is it a Win 10 update?  I've tried everything I could find in other related discussions.  

Looks like I need a new solution

1 answer

FYI, I just downloaded SourceTreeSetup_1.7.0.32509 And it installed perfectly.  There is something broken with the current version.  I'm thinking it may conflict with an Windows 10 update that just came out.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

571 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you