SourceTree external diff crashes Git with libiconv-2.dll missing

Various commands, including external diffing crashes the Git executable.  The commands don't run. The popup dialog is:

git.exe - System Error.  "The program can't start because libiconv-2.dll is missing from your computer. Try reinstalling the program to fix this problem."

 

I have tried configuring SourceTree to use the embedded and system Git with no differences.  System Git is Msysgit 1.9.5.

5 answers

HI. My solution was simple:

  1. Open the "Option" window.
  2. Select "Git".
  3. Than "Use System Git".
  4. And press OK button.
  • Screenshot (46).png

This fixed it for me smile Thanks, that was bugging me for like a week.

This has started happening for me as well...

 

Basically cannot use SourceTree on Windows anymore...  I have reinstalled several times, configured to use Embedded git and not Embedded... Reinstalled git....

Nothing helps.

Git, Githuib both work..... but SourceTree just gives error

Completely broken.

 

Not sure what else to try.,

sad

BTW - http://stackoverflow.com/questions/3431361/git-for-windows-the-program-cant-start-because-libiconv2-dll-is-missing fixes it....

 

But what is the point of Embedded Git in SourceTree if it relies on external git?

 

 

I had the same problems and I tried all the possibilities copying the dll all around. SourceTree version 1.6.25. I never changed the embedded/system Git version option. I think it happens because I unistalled old Git (version 1.8.3) with the curent one (I also have TortoiseGit correctly installed). Now my Git is 2.6.3. At the end I solved the problem with this: Tools >> Options >> Git >> Update embedded Git. It pass from 1.9.5 to 2.6.1. and now it works. Alessandro

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 11, 2018 in Sourcetree

Tip from the team: debugging Sourcetree

Supported Platforms macOS Windows If you're reading this and it's not just educational… we know you're unhappy right now and apologize for that   We're dedicated to improving yo...

668 views 9 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you