SourceTree Windows Setup (2.1.2.5) Download Link Broken

Hello,

The download link for SourceTree for Windows does not download the correct setup file.

  1. Go to https://www.sourcetreeapp.com/
  2. Click the button [Download for Windows]

Expected Download: SourceTreeSetup-2.1.2.5.exe

Actual download: SourceTreeSetup-2.1.2.5.1493845207

Thanks

1 answer

0 votes

Hi Laine,

I've just tried downloading the file and I got SourceTreeSetup-2.1.2.5.exe. Are you using Internet Explorer by any chance? Can you try a different browser and let us know?

Cheers!

Ana

Hi Ana,

Thanks for the reply.

It is weird though - Why would it be different between browsers, it is just a download.

Anyway, I was able to download setup.exe using Chrome.

Now the issue is that when I run setup it does not install the SourceTree, instead it unzips the SourceTree to AppData\Local\SourceTree. Is this the expected behaviour? I would expect it to be installed into "Program Files".

FYI:

I see the same scenario when I downloaded using IE and renamed it to an setup.exe. When run, it unzips the SourceTree to AppData\Local\SourceTree.

Thanks.

Laine

 

 

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

241 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot