SourceTree - Hosted Repositories window is empty

Hi everyone,

I've just downloaded SourceTree and added my BitBucket account, but when I try to clone a repository I've been given access to, the Hosted Repositories window is empty.

If I go to the BitBucket website and clone the repository from there it works fine, but for some reason the SourceTree client just isn't picking up the list of repositories I have access to.

I'm not getting any error messages of any kind.

Does anyone have any idea what I need to change / double check to get this working?

 

7 answers

I never did find a solution.

After a bit of Googling I came to the conclusion that SourceTree doesn't show all the repositories you have access to by default. Instead it only shows specific repositories based on the owner, permissions, etc. Which would fit in with the solution you've described.

I stopped using SourceTree shortly after posting this question, so I stopped search for a solution.

Assuming I'm right, they just need to add some more finely tunable settings for which repositories do or don't show up in the list.

FYI - I'm on Windows 7.

On the top right of the Hosted Repositories window, there is an "Edit accounts" button. Click that and make sure you have an entry for your BitBucket account.

Yes I do. Details are as follows: Hosting Service: BitBucket Host URL: https://bitbucket.org Username: [correct username entered] Login Status: Password OK Preferred Protocol: SSH Show Private Repositories: [checked]

Can you try with HTTP? And/or, check your (company's) firewall settings. It might be that something blocks the transfer.

I've tried with 'Preferred Protocol' set to both HTTPS and SSL, but neither option appears to make any difference. I'm not behind a company firewall, I just have a standard 4 port router and Windows 7 - neither have any special configuration. Although I haven't set up any special rules on the computer or the router for SourceTree either. Would that be worth trying?

Check the Windows firewall, it might be blocking it. You could also try bypassing the router. Something is definitely blocking the traffic.

I just tried turning off Windows Firewall, and enabled DMZ on my router for my local IP. However I'm still getting the problem.

I been having the same problem I found it was because of a repository that was over the 2gb limit ( accidentally committed files that didn't need to go). Must be some bug that causes it not to display any repository if one is read only. It Seems to be only a Windows issue as my mac didn't have the same problem.

Thanks for the info. Although in my case I have access to 10 or so repositories, some of which are < 10MB, and none of them show up in my Hosted Repositories window.

Did you ever find the solution?? The same thing is happening to me

There's no mention of the OS that SourceTree is installed on and wonder if that is a factor?  In my workplace, we have at least two machines that are having the same issue, both Windows 10 1607 build.  It seems to work OK on a Windows 7 machine so possibly some config issue on Windows 10? 

 

Windows Server 2016  / Windows 10

Who would use Win 7 if SourceTree is for developers ??? Win 7 is long gone if you're Windows developer (unless you're working on legacy code)

In my case, the problem was to do with permissions. The Bitbucket administrator changed some settings and it was fixed.

Unfortunately not the case for us. Users are assigned as Admin users, beside it worked before restarting SourceTree.

 

Happens on all machines (even machine hosting BitBucket)

SourceTree is useless. Works only one time, after that won't show the repositories on own server bitbucket (who would ever share own code with 3rd party, no idea, but seems like most of people using it with BitBucker cloud).

 

Don't bother, never use it. I had the same issue few months ago, and now after few months, they have failed to repair this bug.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

707 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you