SourceTree 1.8 doesn't recognize system Git

I just upgraded to 1.8 and after logging in, every single repo popped up an error prompt with "git status failed with code -1."  I looked this up and the results said that the problem was that SourceTree didn't recognize my system's git.  But it worked just fine in 1.7!  I have it in my Path environment variable, so I don't know what could possibly be the problem.

I don't give a crap about the graphical changes.  I could take them or leave them - I honestly couldn't care less.  But it's absolutely unacceptable to completely break AN INTEGRAL FUNCTIONALITY that worked perfectly in previous versions.  I will be reverting to a previous version, and if Atlassian continues to ignore Windows users, I will discontinue using this product altogether.

1 answer

I had the same issue. I uninstalled the 1.8 release and went back to 1.7. Unfortunately even the 1.7 version doesn't work as well as the 1.6.x release that I 'upgraded' from. I suspect some configuration information got lost in the process. I can view my repositories, but I can't push to the remotes. Very sorry that I 'upgraded'.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

845 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you