SourceTree 1.10.20.1 installer won't run on Win 10 64bit - updating to latest 1.9 actually installs 1.10 and then refuses to start

I can't get the installer to even execute. Tried uninstalling and re-installing this morning when I couldn't start SourceTree. Nothing helped, tried reinstalling an old version and updating to the latest 1.9 (don't recall what that was as of writing but it was in the updater) - but then after that completed I see that it's referencing app-1.10.20.1 in the APPDATA SourceTree local folder and I can't start SourceTree again - not even a background process exists after running.

1 answer

I had the same experience.  Had to remove both versions of sourcetree and reinstall the older version from scratch

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

570 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you