SourceTree 1.10.20.1 installer won't run on Win 10 64bit - updating to latest 1.9 actually installs 1.10 and then refuses to start

I can't get the installer to even execute. Tried uninstalling and re-installing this morning when I couldn't start SourceTree. Nothing helped, tried reinstalling an old version and updating to the latest 1.9 (don't recall what that was as of writing but it was in the updater) - but then after that completed I see that it's referencing app-1.10.20.1 in the APPDATA SourceTree local folder and I can't start SourceTree again - not even a background process exists after running.

1 answer

I had the same experience.  Had to remove both versions of sourcetree and reinstall the older version from scratch

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

837 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you