Source Tree update fails?

I'm currently using Source Tree 1.4.4.2 on Mac OS X (10.6.8). I've attempted to update to 1.5.3 (Source Tree > Check for Updates > Install Updates), but it fails.

My Mac is configured so that it has multiple accounts, and the account that I usually use is not the root administrator account, even though it has admin rights.

When I attempt to update, Source Tree successfully downloads the compressed update but it cannot extract the file. The failure to extract the update occurs regardless of whether I update Source Tree from root or
my user account with admin rights.

5 answers

Please manually download SourceTree 1.5.x from http://www.sourcetreeapp.com and just drag & drop it into your Applications folder this one time. A bug in Mac OS X 10.6 started causing problems for the auto-update from SourceTree 1.4.3, we've worked around this in 1.5+ but you need to manually update once to get the fix. From then on auto-updates will work on 10.6 again. Mac OS X 10.7 and 10.8 were not affected.

I have 2.0.5.6 and getting an error when trying to upgrade to 2.0.5.7. It downloads 47.1 of 47.2 MB and shows an error message that the upgrade failed. Tried many times.

Hey,

this update-problem happen to me in every version of SourceTree. The download seems not to complete at the end. I've always download the setup from the website, but this download also sleeps at the end of the download for approximately 100 seconds. I think thats a server-side problem.

I have this problem on Windows and on Mac, in different locations with different internet connections.

Please check that, it is really annoying to always update manually.

 

Greetings

Tonka 

The update fails for me too. It seems to get very close to the end of the download, e.g. the text on the progress meter would imply it's in the last 1k of download, then it fails. When I download from the website the last portion of the download took quite a while, ~1.5minutes for the last k of download.

Could the update be failing because of a slow download?

Exactly the same issue here. Sourcetree has done this for every update for the last few months. The same happens in the browser, but then the download finishes after about 100 seconds as tonka3000 found. Maybe the updater gives up before this time?

Any ideas why this may be @Steve Streeting ?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

425 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you