[Source Tree] ssh-agent.exe unable to start

Hi everyone, i got a new computer and try to install Source tree on it but got this error message when i try to launch ssh-agent (Tools> lauch SSH agent...) :

'ssh-agent' failed with code-1: System.Exception: Unable to to start 'C:\Users\myaccount\AppData\Local\Atlassian\SourceTree\git_local\bin\ssh-agent.exe' check the git installation ()

My former PC runs on windows 7 and my new windows 10. I look in the "bin" folder and there is no ssh-agent.exe there but in git_local i got a usr folder in which i found a new "bin" folder in which a ssh-agent.exe file is.

I tried to :

  • change the path but found no way to do so.
  • copy-paste the "usr/bin" folder in the "bin" folder but it did not solve my problem.

Please, how can i fix this?

Thanking you in advance

 

 

1 answer

1 accepted

This widget could not be displayed.

Hello there, 

 

Looks like SourceTree is looking for ssh on Git Embedded while you are using a System Git. For testing purposes, can you try to change for Embedded Git? You can do this going to SourceTree Menu -> Preferences - Git.

 

Cheers, 

Renato Rudnicki

I've tried but it didn't work. I also tried to set again System Git and now it works. Thank you

Hello, If you find this answer useful, I would kindly ask you to accept it so the same will be visible to others who might be facing the same issue you have inquired.

After upgrading to version 1.8.1.0 I started to see a similar ssh-agent failure - switching to System Git fixed this for me.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

729 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you