It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SCM stopped working?

Hi, I have both Sourcetree and Tortoise installed in Windows 7. I was running older versions of both and decided to update Sourcetree first, Tortoise second.

Tortoise projects are working fine but every time Sourcetree tries to connect to the repository (Pull) it pops up a window saying: "Fast scalable distributed SCM (revision control, version control) system has stopped working". I tried reinstalling/repairing both Sourcetree and Tortoise but not luck so far :/

Any ideas? Thanks in advance!

1 answer

0 votes
Mike Corsaro Atlassian Team Apr 02, 2018

Hello! So it sounds like something is wrong with your Git install. Could you try switching from "System Git" to "Embedded Git" (or vice-versa) in "Tools > Options > Git" and see if that helps? Thanks!

Hi Mike! Thanks for the reply. I switched between both "System Git" and "Embedded Git" several times, also tried updating the embedded Git (and Mercurial as well, just in case) and tried to use system Git (and Mercurial) pathing to all possible .exe's I could find (all dated 2017) - nothing worked :(

Mike Corsaro Atlassian Team Apr 02, 2018

Could you try and run the command from the command-line and see if that works? Just open the repo, click the "Terminal" button and try running "git pull" and see if it crashes.

"git pull" returns "git is not recognized as an internal or external command, operable program or batch file." but "hg pull" returns a "pull from repo address" message and then it pops up the error window (it doesn't exactly crash Sourcetree).

Mike Corsaro Atlassian Team Apr 03, 2018

Sounds like git isn't in your system PATH. Could you try downloading and re-installing git? 

Download the most recent one (2.17), didn't work :( uninstalled it and tried to use the embedded one again (2.15.1), still didn't work.

Tried "git pull" on both occasions, same message as before. Also tried to disable LibGit2 integration and checked my Firewall settings, nothing worked.

I logged in my Bitbucket account and tried to clone the repository again, it pops up the error window. Looks like there's something blocking the connection between Sourcetree and the repositories on both projects I'm working on.

Hi,

I'm facing the VERY same problem than Eduardo. Tried everything he tried so far, and also is not working for me as well.

Any idea?

/Fabio

Mike Corsaro Atlassian Team Aug 09, 2018

Hello! There's a known issue with the git-credential-manager that might be the root cause of this. Please take a look at this:

https://community.atlassian.com/t5/Sourcetree-discussions/dev-team-Known-Issue-Bitbucket-Login-with-Git-Credential-Manager/td-p/863235

Hi Mike,

Thanks for your reply. But unfortunately i can't find myself in any of that scenario described on your link. I'm not using/authenticating with bitbucket. I'm actually trying to Clone from a git repo inside TFS tool on my company. Anyway i'll try a few more things, in other computer and maybe another tool as well.

Thanks for you support. 

Hey Fabio,

I upgraded my Windows 7 to 10 and it solved the issue - everything else I tried didn't work :/

Hi Eduardo,

That’s definitely not an exciting news, but even though is really good to know. Fortunately in the company that I work we are in process to migrate from win7 to win10. 

Thank you very much for your input here.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,907 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you