Push pull red icons / notifications not showing

Our team had just started using Sourcetree. Initially everything was fine, but on one of the machines the push and pull notifications showing how many commits are waiting to be pushed/pulled are not showing up. We expect to see them next to the push and pull buttons on the source tree user interface:

Making commits to the local repo does not trigger the push icon to appear. Using sourcetree on another machine and pushing changes to the bitbucket repo does not cause the pull icon to appear on the problem machine. It is still possible to push and pull files.

I have set the 'check default remotes for updates every' to '2' minutes. And have tried clicking Repository > 'Refresh Remote Status' on the toolbar.

I have tried repeatedly setting up new repos on bitbucket and connecting them to new repos on sourcetree. I have tried having different files in the repos to check they are not responsible for the problem.

The counters in the branch list are working on colleagues machines, but not on mine.

I have tried uninstalling Sourcetree and reinstalling it.

The problem machine is on OSX 10.9.2, 3.5 GHz i7, 16GB RAM

I am not sure what to do next to try and solve this issue. Without this feature it is going to be hard to know when pushes and pulls are required.

1 answer

Push and pull notifications will only show for the currently checked-out branch, and only if that branch tracks a remote branch.

I've never had a problem with the push counter, but sometimes my top pull counter fails to update itself if I switch to a branch that needs pulled. However, the counters in the branch list always work reliably for me. Are those working for you?

Hi Seth, That is interesting that your pull counter fails to update itself if you switch to a branch that needs to be pulled.

The counters in the branch list are working on colleagues machines, but not on mine.

Odd. I've never seen that behavior, but someone else may have.

If you don't get an answer in the next few days, I would recommend posting a support request on support.atlassian.com

Did this issues ever get resolved? I have 2 machines running SourcreTree (work and home to the same repo). My home machine is still working fine but the red badges on the top bar and the branches list have disappeared from my work machine. I think this is due to a power cut midway through a checkout process. I reverted the changes causes by the failed checkout and everything seemed to go back to normal apart from the icons.

Have you tried re-cloning your repository on that machine, or re-installing Sourcetree?

I have a very similar problem... . You can do the normal things with right click on the origin, but right clicking on the local branch the tracked options are greyed out. However you can do the things via the menus. Choosing track remote branch you can see it is set to "none". This makes sense that sourcetree/git cant see how far ahead/behind you are if you dont have a base on the origin. I have tried setting tracked to the origin. You get a nice warning message, but pulling up track remote branch you can see it is still set to "none". I have tried pulling new branches and these dont seem to seemed to be tracked either.MMmm. It started after an update. I might try Seth's idea of reinstalling but if I have to do that, I think I'll thow my laptop out and start afresh instead. :-). Ill keep digging around, I have used the menys for about 2 months now, another month wont matter

If your branch is not tracking origin because it doesn't exist on origin yet, you'll need to push it there first. What does the warning message that you mentioned say?

"Are you sure you want your local branch "Development" to track remote branch 'orgin/Development' in future?" Ive had further look around and commandline git is moaning about SSH Keys. I can see our IT team have shift our home page to another drive, but the .SSH folder and known hosts file does exist. It might be connected but I a guy here doesnt think so as I can push fine via the menu bar. I will try and sort this and maybe it'll fix the tracking

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

849 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you