It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Push falied even my credentials are correct. Endless requirement to reconnect my account. Edited

When I push a commit, it gives this error:

 

Pushing to https://bitbucket.org/blabla/blabla.git

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

fatal: Authentication failed for 'https://bitbucket.org/blabla/blabla.git/'


My account is already defined in settings, but I have to go Preferences > Accounts and reconnect my account entering the credentials. It gives me only one chance to push the last commit. Then when I want to push more commits, it gives the same error and I find myself in an infinite loop.

 

I tried to push in console, it also asks me my credentials before push. Where is the mistake that I miss?

 

1 answer

0 votes
Manju Atlassian Team Jan 24, 2018

Can you please confirm what authentication method and protocol you are using when you add the account in Sourcetree?

Auth type: OAuth

Protocol: HTTPS

OS: MacOS

 

Update: I can now push commits via console without entering credentials, but GUI still fails.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,989 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you