It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Oops, you've made a malformed request.

Oops, you've made a malformed request.

Often, clearing your browsers cache and restarting your browser will solve this problem.
If that doesn't work, please contact support.

 

I get this message whilst trying to log into the sourcetree app. I have cleared my cache in both firefox and internet explorer, though I only use firefox.

4 answers

If you still need a solution, this worked for me (Windows 7, SourceTree 2.3.5). Go to Control Panel>Network and Internet>Internet Options. Go to the Privacy tab and set the Internet zone setting slider all the way down to "Accept All Cookies".

Install the app, register/login and then when done turn the setting back to whatever it was before.

I tried Ana's solution first and it didn't work but I still had those changes enabled when I tried my solution, I don't think that affected things but mentioning it just in case.

Hi

I have tried your solution as well, sadly for me did not work.

I went through all the IE settings and allowed / enabled everything, when doing so it would just sit there with the login button spinning rather than returning malformed request. Not sure if this is progress but it is change.

 

I will also try this from home, in case there is something on this network causing the issue.

thanks for the suggestion though

Worked for me on Windows Server 2012 / Internet Explorer 11

0 votes
Ana Retamal Atlassian Team Dec 13, 2017

Hi Marco, Sourcetree for Windows uses Internet Explorer for authentication, can you make sure you're in an updated version? If you already are, please try the following:

  • Disable browser extensions or try in private browsing mode.
  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear
  2. Select "Internet Options"
  3. Select the "Security" tab
  4. Select "Custom Level" for Internet
  5. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  6. Try logging into Sourcetree again

After logging in, follow steps 1-5, but reset the setting back to the previous option.

 

If after that you're still having trouble, let us know which version of Sourcetree, IE and Windows are you using so we can continue helping you :)

Best regards,

Ana

Hi thanks for your help, I'm still getting the same issue.

I'm using sourcetree 2.3.5, Windows 7, Internet Explorer 11

Hi Ana

 

I am also getting the same issue,

I have tried your suggestions above, with no joy.

I have tried source tree 2.3.5 and 2.1.11.0, IE 11.0.96 running windows 7

 

any more suggestions welcome.

Best Regards,

Jonathan

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you