Moved from OS X to Windows, repo has lots of uncommitted changes

I just move a Git repository from OS X to Windows (I copy-pasted it) and now both text and binary files (PNG, TTF) have uncommitted changes. When I click an individual file to see what's changed, SourceTree doesn't show any differences.

I suspect this has something to do with line endings. I tried creating a .gitattributes file that marked PNG and TTF files as binary, hoping that Git would ignore them, but it didn't work (it made no difference).

*.png binary
*.ttf binary

I have difficulty in solving this problem because I don't know for sure what the cause is, because I don't know what the solution should look like, and I don't know how to actually implement the solution (I'm new to Git).

How ca this problem be solved? 

1 answer

0 vote
Timothy Chin Community Champion Oct 08, 2014

And how did you move? Copy & paste?

The proper way should be a git clone --bare. Go ahead and Google the solution. smile

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot