Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,902
Community Members
 
Community Events
168
Community Groups

Login to Bitbucket server doesn't work

 Whatever I try, I can't get the login to Bitbucket server working with Sourcetree 2.6.10.0. It's just like Sourcetree doesn't even try to use the host URL which, in my case, is https://x.y.net/bitbucket.

Is there someone out there who could give a hint?

I have already tried

* deleting credentials in den Windows credential manager

* deleting the AppData\Local\Atlassian\SourceTree folder

* all thinkable combinations for the host URL, like https://x.y.net/bitbucket, git;https://x.y.net/bitbucket, https://<username>@x.y.net/bitbucket, etc. etc.

Help, please!

1 answer

0 votes
Ana Retamal Atlassian Team Oct 01, 2018

Hi Matthias! 

Please provide some more information so we can help you troubleshoot this:

  1. Are you using Sourcetree for Windows or for Mac?
  2. Can you confirm that you've already followed the steps at Set up Sourcetree to work with Bitbucket Server?
  3. Have you double-checked that you're using the right credentials? Are you entering your username or your email address?
  4. Are you getting some kind of error? Can you send a screenshot?

Cheers!

Ana

Hi Ana,

many thanks for your reply, and your help!

1. Windows

2. Yes, except for the fact that I had to use my Atlassian account for initial registration.

3. Yes. I'm an admin for the Bitbucket server platform, and I'm using my username and password - just like for the direct login to Bitbucket (which is working fine).

4. Glad to. What strikes me - apart from the fact that the login doesn't work ;-) - is that the error message does not include the full base URL,"/bitbucket" is missing.

2018-10-01 10_37_00-Edit Hosting Account.png

Cheers

matthias

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events