Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Location of Windows Install - 3.3.8

Good evening!

Just a brief rundown of the specs of my computer... Windows 10 64-bit, 32 GB DDR3 RAM, RTX 2070 with an AMD FX-8750.

I wanted to quickly see where the company has determined would be the best place to place the installed folder for Atlassian Sourcetree. I noticed that the installer creates a folder in "C:\Users\[My user]\AppData\Local\Atlassian". In the "Sourcetree" directory within the root folder, sadly, there is no ".exe" located there. Instead I am met with the following files:

  • cache,
  • git_extras,
  • hg_extras,
  • analytics_gas_upload,
  • bookmarks.xml,
  • mcmw.zip,
  • settings.log,
  • sourcetree.log, and
  • [a json file with tokens]

Back in that root folder, I see one more directory:

  • SourceTree.exe_Url_[token info]

Diving inside it only provides another directory with "3.3.8.3848" and a few cache files, profile file and a config file inside. that directory.

 

This seems to be an issue. Can this be elevated?

 

Additionally, it appears that the install file from this website also acts as a launch file (which means, each time I run Sourcetree, I must run the install file to run Sourcetree... It's a little backwards). Can this be confirmed?

 

I regrettably must inform that AppData\Roaming does not contain any inkling of Sourcetree and AppData\LocalLow is also empty, in terms of Sourcetree.

 

Kind Regards,

Jeff

2 answers

The installer creates the "C:\Users\[My user]\AppData\Local\Atlassian\SourceTree*" set of subdirectories, which you've already identified.

In addition, it should also create "C:\Users\[My user]\AppData\Local\SourceTree". The actual executable should be stored there.

Different components of the overall application appear to be spread across all of these directories.

Something similar happened to me... there is no Sourcetree app installed in the system, I have to run the installer every time I want to run the app.

I already tried installing/reinstalling, but the installer don't go through the installation process, it just opens the app (with is kite slow)

Is there a Workaround??

SourceTree_installation_issue.png

(I am assuming you're using Windows 10:)

One workaround is to navigate Windows Explorer to "C:\Users\[My user]\AppData\Local\SourceTree", locate the application "SourceTree.exe", right-click it, and select "Pin to Start".

Alternatively, or in addition, you could also select "Pin to taskbar".

Like Andres_Cichero likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events