Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Local repository shared by multiple people?

Hello, I am very new to source tree and this might be answered before but if it is, I couldn't find it. So here we go;

I want to work on a project with my friend. We have a small office-like place, we both have a computer and there is 1 server we use to share files easily. Both computers are connected to that server disk. So what I want to do, create a project on that server so, when I make a change on my computer and push it to the server, he can pull from the server to his own computer and keep working. 

Here is a demonstration if needed; 

http://prntscr.com/ilv2zz

 

Note, I tried creating a repository on server, cloning it to my computer, making a change on my computer and pushing it to server (was just a text file to see if it works). It gave me a lot of error. Something about "ignoreBranch". 

1 answer

1 vote
Ana Retamal Atlassian Team Mar 02, 2018

Hi! For troubleshooting purposes, have you tried pushing from the command line? If you're getting errors in the command line too, then the problem is not in Sourcetree and we'll need to find what's wrong. 

If the command line is working and you only get the error in Sourcetree, then we'll need more info to understand what's happening?:

- Is your friend also getting an error when trying to push?

- Can you be more specific about the error you're getting? Can you copy it here or send a screenshot?

- Are you using Windows or Mac? Which version of Sourcetree are you using?

Let us know!

Ana

Hi, thanks for quick answer. 

So, I create have a server, which is 192.168.xxx.xxx, I create a repository on there called TestRepoOnSW, after that, I go to my source tree and clone that repository to my computer, which is named as TestRepoOnMyComputer. Then I make a change on my computer, I add an empty .txt to the repository on my computer and try to push it.

Here is the error;

http://prntscr.com/ilwwdb

-I am sorry I do not know how to push from command line. I am very, very new to it. So sorry :)

-Haven't tried to push from my friends computer because I want it to work on mine before I set it up to my friends computer.

-I am using windows and Sourcetree version of 2.4.8.0

Thanks in advance.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,782 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you