Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Loading Owners Failed with Sourcetree Mac

Edited

Hi Guys,

 

Today Sourcetree for Mac can't see my team Repository

and When I trying to create a Repository it showing

Loading Owners Failed

message: This endpoint has been removed. See our documentation for more information. https://developer.atlassian.com/cloud/bitbucket/rest/api-group-teams/#api-user-permissions-teams-get

I checked this url https://developer.atlassian.com/cloud/bitbucket/rest/api-group-teams/#api-user-permissions-teams-get

 List team permissions for the user DEPRECATED

 

Sourcetree 4.1.5 is currently the newest version available.

Does the last Sourcetree for Mac can't compatible with the latest API of bitbucket Cloud?

Thank you

17 answers

We also have the same error since yesterday. API endpoint deprecated. Sourcetree Mac version 4.1.5.

Can someone have a look at this?

Same issue, none of the suggested fixes work - even uninstalling and reinstall results in same error message

Really need to wait for a new version of Sourcetree to be released

One method is adding the repo to BitBucket first, then cloning that to the desired location which will then allow you to commit to remote repo (act normally) 

 

I also can't believe this still hasn't been fixed... 

It's been a year now. Any plans to fix this?

yes it's unbelievable - also working on mac (m1) and still the same error since over a year now ... can't understand why this is not getting fixed..

This issue has been resolved in version 4.2.2(250).

Like brainforge likes this

Indeed… thx for answering quite fast..

for anyone else stumbeling across this issue - in order to fix it i also had to generate an api key for my account after that it worked..

the only thing still not working is when itry to clone a remote directory after creating it - i always get an error that says the url is not valid… wheni try the to clone from url option and paste the url from bitbucket online then it works..

It's still an issue for me on 4.2.0 (246). 

July 30th 2022, still happening, just came here from a Google search.

I KNOW I can make the repo online and then copy my data over, but that's not really the point is it...

Can anyone please do or say anything about this? I'm on version 4.1.9 on Mac and it doesn't work!

Like # people like this

It's over 1 month and still doesn't work. Any plans to fix it?

Surprisingly, it's Feb 2023 and it's still not fixed. Lacklustre performance Atlassian. Do Better.

I am experiencing the same issue on 4.1.6

me too! is there a solution?

Same here when trying to create remote repo.

But I can push to existing remote repos.


A workaround that works for me is to create the repo online and clone it locally.
Then move your project files to this location OR move the .git folder from the cloned location to your working directory.

We are also having this issue. Some team-members cannot see any shared Workspace repos, and none of us can create remote repos because Sourcetree still tries to use the Owner endpoint. 

I've have given up on Sourcetree and migrated to github & Github Desktop client is quite stable.

it has been ages and still this issue is not fixed also source tree is not working properly for apple M1 & M2. 

Is there still no solution to this?

Still no resolution to this and it's now the end of August.

 

Atlassian need to get on this!!

Any update here? Still having the same issue?

So it is April (2022) now, I'm running Sourcetree 4.1.8 (243) which according to the "Check for Updates" should be the current version and I'm still getting this error while trying to create a remote repository. 

Any solutions coming?

If there is a solution to be found somewhere else, my apologies but this thread is the first result I get when searching Google.

The workaround mentioned by @Arno Kools seems to also work for me.

  • Create a repository on the Bitbucket website
  • Clone that repository to the required local location using "Clone in Sourcetree"
  • Move the files to the local repository
  • Commit and Push in Sourcetree
Like Venkat Krisshna likes this

Thank you very much for this suggestion. I did this and was able to publish my repo to remote.

This issue is still not fixed :/

Any updates on this issue?

You really should read the forum before posting - almost every post now is about this. They wrote in one of the first ones that it would took them 2 weeks to fix, one week has passed, so waiting...

This is a non-contribution. Not sure what you mean "the forum" this IS the forum, no? Or you mean the Open Issues log? Either way, this is the now the first hit on Google for me searching for the issue. 

Like # people like this

ya no luck I'm back to cli

The "2 weeks" has passed a month ago...

Like iforabe likes this

still not fixed in august 2022... version 4.1.9 (245), this is getting silly, either fix it or remove the interface and wizard, but don't leave a feature hanging like that, that doesn't work for so many month now...

Like RubenAh likes this

It's ridiculous, isn't it? You know something is wrong when a company can't even stay up to date with their own API (for months!). At this point, I'm only subscribed to this topic out of sheer curiosity. 

As an actual solution, I recommend switching to something like GitKraken and saving yourself the headache.

yep, they are ruining their reputations on this. the frustration is growing, maybe things are not going so well, because I just can't explain otherwise to leave such important issues unattended, this is what made sourcetree better than other solutions. Now, what's left that justifies using it... we are indeed switching...

Like RubenAh likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events