Invalid username or password and push succeeds for a couple times and then fails, requiring re-auth

Every push generates the authentication warning below but the push works. However, after several times, it will stop working with an error about too many login attempts and I have to re-enter my Bitbucket credentials. I do not have 2factor on.

This started happening with a Sourcetree upgrade that took place within the last 2-3 weeks. Only happens on Mac.

1 answer

1 accepted

1 vote
Accepted answer
Jesse Yowell Atlassian Team Aug 31, 2017

Ian,

What is the auth and the protocol used for auth? (i.e. SSH / OAuth)

Also, is your URL different than the protocol used for authentication (for example.. HTTPS?)

Thanks Jesse, your answer pointed me in the right direction. I messed up the setup of SourceTree on my new laptop.After changing account authentication to Basic and SSH, the error no longer appears.

Jesse Yowell Atlassian Team Sep 01, 2017

No worries! Glad we could help

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

736 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you