Inconsistent "Finish Feature" behavior in deleting remote branch

Hi, we have created a feature branch and used the Git-Flow -->"Finish Feature" functionality to commit changes from local SourceTree repository to remote GitHub repository with "Delete branch - After finishing" option but the behavior is inconsistent. For some users, it deletes the feature branch locally and retains the branch in remote GitHub repository but for others it deletes the branch in both local & remote. So is there any specific configuration or setting that is causing this inconsistent behavior? If so, can someone provide the details?

  

1 answer

0 votes

What version of Sourcetree are you using?

What OS are you on?

Brian - Thanks for your response. We are using SourceTree version 2.4.7.0 on Windows 7 Enterprise Service Pack 1

Brian - were  you able to review the information I have provided and come up with root cause / solution? If you need any other info to triage this further please let me know.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

238 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot