I have installed Sourcetree and its registered but UI is missing items and I cannot import licence

Ok, so I downloaded the sourcetree exe, installed it, registered it and it was working fine but now the UI will not show the repositories in the main window. I can see them in the left hand pane but a lot of the menus are greyed out. I tried reinstalling, tried finding the licence file (which I still cannot find) so am a little confused as to why this has happened. I use GITHub for windows alongside it.

I tried registartion again but just got a window that says I am registered and when I tried to import the licence from:

C:\Program Files (x86)\Atlassian\SourceTree\extras\licenses

I could not find the file as there is no reference to the name it is under or what type of file it is, though I would assume it is a .lic file though I may be incorrect

If anyone can shed some light on this (preferably not a url to a FAQ page) I would appreciate it.

14 answers

This widget could not be displayed.

Hey Malcolm,

It sounds to me like you've not double clicked on any of the repositories in the left-hand pane. The buttons won't be available because no repos are open. The left hand bar is a bookmarks pane, it's not a selection pane. Repositories are opened in tabs along the top of the screen once you open repositories.

Cheers

This widget could not be displayed.

SourceTree can exhibit some random UI problems when there is funny business with the Windows theme. Right click on the desktop and click "Personalize", and make sure the selected theme isn't displaying a black rectangle where the background image(s) should be. If in doubt, try switching to one of the Windows Default Themes.

This widget could not be displayed.

No, that did not work, I already had Aero turned off with a Windows 7 theme and had a solid colour bg. It was working fine, but now is causing issues for our dev team.

This widget could not be displayed.

Still no resolution to this issue. I have reinstalled it, but the ui elements are still missing. I have tried several times to get feedback and help but there does not seem to be any forthcoming. Fundamental and obvious things I have tried have only been repeated in the one piece of feedback I have recieved. I just do not use it now and am looking for an alternative as I cannot continue to not be able to work with my projects.

This widget could not be displayed.

No, that does not work either and I have just updated the app as well to version 1.4.0.0. I do understand how it works as I had been using it fine, it just stopped showing the repsoitories in the middle pane, despite the bookmarks being there and double clicking the item I want to show. I have pretty much tried all the obvious things, so there has to be something else going on. I have double, triple, quadruple clicked on the left hand pane items and still no items in the centre pane. I can right click on the item in the left hand list and show it in explorer, but this is not what I want. I want to be able to see the repository in the centre pane. If I right click and choose open, nothing happens. All the buttons along the top are greyed out apart from Clone/new and open terminal. In fact, nearly all the items in all the menus are greyed out and I cannot do anything.

source tree UI issue

The link to the image is to your computer, could you upload the image? Use the 'up' arrow when posting to upload an image.

Cheers

This widget could not be displayed.

Yeah there's no open repositories here. As I say, the left-hand view is the bookmarks view, you need to open. You can either double click on a repository in that panel or right click on it and hit 'Open'.

Cheers

This widget could not be displayed.

I have tried dbl clicking the repo, but on trying to open the repository, I get the following error box. I have been using GIT for windows to sync the updates from my local to the master repo kept on our server, which does work, I just cannot seem to get Sourcetree to recognise the repos. What have I done wrong here?

Hey Malcolm,

There's various reasons this could happen. Have you checked that path to see if the repository exists there? And if it does, can you run "git status" at the terminal once you've browsed to that location ensuring Git responds as expected?

Cheers

Maybe just remove the repo from SourceTree and add it again (per Drag&Drop form Windows Explorer)

This widget could not be displayed.

yes, the repositories are there, I regularly update them and sync them using GIT, so I do not know why this is coming up.

What does "git status" yield at the command line?

This widget could not be displayed.

whoops, wrong location, here is the right one.

Hey Malcolm,

Could you provide us with your sourcetree.log file located at C:\Users\<username>\AppData\Local\Atlassian\SourceTree?

Thanks in advance

This widget could not be displayed.

This widget could not be displayed.

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'git status' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'git log' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:03: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:03: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:14: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:14: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:40: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:40: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:26:09: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:26:09: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:32:30: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:32:30: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:57:58: Could not determine repository from: 'https://github.com/burrowsyr/robot_tree.git', output was:

2013-12-19T14:58:33: Could not determine repository from: 'https://github.com/burrowsyr/robot_tree.git', output was:

2013-12-19T14:59:01: Could not determine repository from: 'https://MalcArmstrong1970@github.com/burrowsyr/maya_tools.git', output was:

2014-02-06T16:10:22: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2014-02-06T16:10:22: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2014-02-06T16:11:17: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2014-02-06T16:11:17: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

This is probably a stupid question, but are those the correct paths to your repos? On my computer, I've moved My Documents to the D: drive, so I'm thinking maybe a change like that is confusing SourceTree.

This widget could not be displayed.

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'git status' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'git log' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:24:05: 'current revision' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:03: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:03: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:14: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:25:14: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:40: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:25:40: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:26:09: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:26:09: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:32:30: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2013-12-19T14:32:30: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2013-12-19T14:57:58: Could not determine repository from: 'https://github.com/burrowsyr/robot_tree.git', output was:

2013-12-19T14:58:33: Could not determine repository from: 'https://github.com/burrowsyr/robot_tree.git', output was:

2013-12-19T14:59:01: Could not determine repository from: 'https://MalcArmstrong1970@github.com/burrowsyr/maya_tools.git', output was:

2014-02-06T16:10:22: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2014-02-06T16:10:22: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

2014-02-06T16:11:17: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\deadline5)

2014-02-06T16:11:17: 'Summary' failed with code -1: System.ComponentModel.Win32Exception: The system cannot find the file specified

(C:\Users\armstrongm\Documents\GitHub\max_tools)

This widget could not be displayed.

Thanks for the response. I have not changed, moved or altered any data since the first install. all processes are intact. Its baffling and I am trying to recall if anything may have been changed/altered when I was away, but as far as I know, no other member of staff had access to my machine. I have spoken with my dev team and they have not been near it. I am suretherwill be an explanation, so thanks again for looking into this.

This widget could not be displayed.

I have resolved this issue myself by reimaging my machine and reinstalling all the software that I need. The Sourcetree Ui is now back to normal and I am able to use the application as before. I am unsure what went wrong but am glad that I can access the functionality once more.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

710 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you