Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I have an issue with authentication

Good day team, 

I realise with the latest release of Sourcetree, i assume it is Version 2.7.1, it always triggers this alert

 

Cloning into '-'...

warning: templates not found /usr/local/git/share/git-core/templates

remote: Too many invalid password attempts. Try logging in through the website with your password.

fatal: unable to access 'https://-@bitbucket.org/-/-/': The requested URL returned error: 403

"-" just indicates redacted, it is valid data. But thats besides the point. It just seems so broken to me, because every time i want to work from Sourcetree, this error comes up, which has never happened on previous versions of Source. 

I tried a workaround found in the web, which is to reauthenticate in id.atlassian.com; it just fixes the symptom, but it not the problem. 

I hope this can be fixed, something is wrong with your authentication. 

Regards, 

1 answer

0 votes

First thing, please update to the latest version of Sourcetree 2.7.2 (167) that is available as OSX_Latest.zip from https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/

From the details you've mentioned above, I understand that you are using https remote repo URL. Can you also confirm if the bitbucket account you have in Sourcetree is using https too? 

If in case, its ssh, you might want to either fix the account to use https or change your remote url to ssh. 

To change the account to use ssh, just edit the account in the preference window > Accounts tab and select ssh as the protocol. 

If you want to use ssh for remote URLs, in the repository browser window, right click on the repo bookmark and select "Convert to SSH" 

If your problem isn't solved with these steps, please let us know here with the details of what you've tried and the error messages you see.

 

Thanks,
Manjunath
Sourcetree Mac Developer

Tried the beta build. However the same issue still ensues. The repositories are in https, so my approach is fine. I do not think the issue is with how the repository authenticates with sourcetree, it is how sessions are managed for oauth between Google and Atlassian.

It seems like it times out and everytime it is fixed, it is because i logged out and logged back into the service, which should be the case. The timeout should be 30 days, if the box has been ticked, no? 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,344 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you