I can't install SourceTree

I have an account and am trying to setup a new laptop (Win7) but when I enter my email address password field does not appear:

http://prntscr.com/he8j26

The preloader on the Continue button rotates and nothing happens:

http://prntscr.com/he8loq

by clicking on the second button authorization on the site occurs, but the installation does not continue:

http://prntscr.com/he8jng

How do i install SourceTree? I don't understand.

3 answers

1 accepted

0 vote

Hi Danish, we've seen something similar in the past and it was caused by some settings in Internet Explorer, can you try the following:

  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear
  2. Select "Internet Options"
  3. Select the "Security" tab
  4. Select "Custom Level" for Internet
  5. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  6. Try logging into Sourcetree again

After logging in, follow steps 1-5, but reset the setting back to the previous option.

Let us know if it worked for you!

Regards,

Ana

Thank you very much for your answer. It did not work. Even if i disable all Internet Explorer security settings, the password entry field does not appear and i can not enter the account.

Thanks for letting us know. Could you tell us which OS and version of Sourcetree are you using? Are you in a corporate environment, or behind a firewall?

Can you check the logs and see if there are any errors?

Cheers!

Ana

Ana, I managed to solve the problem. A very old Internet Explorer 9 was installed on my laptop. After updating to Internet Explorer 11, the method described by you worked.

Ahh, that makes sense :) For future reference, you can find a list of supported browsers at Atlassian supported browsers.

Have a good day!

Ana

Hi all,

i have the same problem with firefox on (laptop/win7).

what can i do ?

Hi! Sourcetree actually uses Internet Explorer for the authentication, so please follow the advice given above and let us know if it worked for you :)

Best regards,

Ana

thanks Ana for your reply.

i just install specially for you internet explorer. a very bad news for devcomputer.  :(

so, install is now ok.

have a good day

Hi @yTy, I understand having to install IE is not ideal. The reason why we need it is because Sourcetree relies on running a controlled web session to allow user's to interact with Atlassian account and detect a successful login. The WPF WebViewer control is built upon IE and inherits its configuration, some of which we can override, some we can't.

Theoretically there are alternatives to the IE WebViewer control, but they generally involve bundling something like CEFSharp which would considerably increase the download size. Having said that, we're looking at all options.

Have a good day!

Ana

@Ana Retamal Ortiz

I believe there should be some other option for users who are unable to adjust their IE settings. Namely, users such as myself who are on corporate computers which disallow adjusting any of the settings you have mentioned.

I noticed that when signing up for an Atlassian ID and getting a license to sourcetree, I am able to download the license file. 

So why does sourcetree itself not allow consuming this file instead of [or alternatively to] using a sketchy browser-based authentication?

Hi @Will Grant, this file is no longer useful as Sourcetree doesn't require licenses any more.

However, I'm happy to announce that we've listened to all the feedback we've received from users that were in a situation similar to yours, and we're already working on a solution for that :) This is still at a very early stage, but we'll share more info as the project progresses. 

You can keep an eye on this ticket SRCTREE-3593 and our blog for future updates.

Cheers!

Ana

Hi Ana, i found you answer very helpful and i manged to install SourceTree on Win 2016 Server, its got quite restrictive settings :).

That said seen as Atlassian are still using IE to get the authentication token can you please ask the developers to consider adding the FEATURE_WEBSOCKET reg key before launching the login window, this should address the settings issue.

 

https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/general-info/ee330736%28v%3dvs.85%29#websocket

I was having the same problem on a fresh install of windows 7.

 

Ana, I managed to solve the problem. A very old Internet Explorer 9 was installed on my laptop. After updating to Internet Explorer 11, the method described by you worked.

 

After upgrading to Internet Explorer 11 the password prompt appeared and I was able to log in.

Happy to hear that! :)

The way to completely sidestep the proxy is described here:

Atlassian Community Question: How to install SourceTree through proxy

With this method, the login request is skipped.

Hello @Peter Wake is it possible you accidentally posted the incorrect link? I followed the one you posted and the most recent comment is actually by you asking for clarification because the steps given don't solve this problem.

No. The link is correct, but magically, the answer I posted to that question has vanished. Almost as if some system or administrator removed it... Possibly because it contained a link to a certain popular coding answers site? I don't know why it vanished. Maybe it was just some random bug, but it was certainly there yesterday.

I've re-posted, without the link, and with simplified formatting. Hopefully this time it sticks. If not, I think we can conclude that Atlassian are opposed to the spirit of the solution, which skips the Atlassian login window entirely.

Haha! Magic indeed... 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

564 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you