It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to solve "Too many invalid password attempts" error, even when using SSH

Since a couple of weeks I can effectively not use SourceTree anymore.

Always when pushing and pulling I get the following message:

remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.

fatal: unable to access 'https://REDACTED@bitbucket.org/REDACTED.git/': SSLRead() return error -9806

 

When I reconnect my account this problem is gone for about 5 minutes, then it returns. So I though I'd be smart and use SSH with a key pair. But even though I have now set the account in SourceTree to use SSH with key pair I still get this exact same error. Of course I also tried the login at atlassian.

I use SourceTree version 2.7.3, with the embedded git version 2.16.2, on Mac OS 10.11.6.

I hope someone know whats up. I'm even more confused why SourceTree still tries to use https when I have set it to SSH.

I can also still push/pull via the command line.

Thanks for your help!

2 answers

0 votes
Ana Retamal Atlassian Team May 07, 2018

Hi! We have a fix coming for this in 2.7.4. Would you be interested to try an early access build and confirm the fix?

Let us know!

Ana

Manju Atlassian Team May 07, 2018

Please find the direct download link for the 2.7.4 beta which includes a fix for this issue here.

Kindly provide feedback if you see any issues with respect to "https" authentication with Bitbucket which returns 403 errors. 

Thanks,
Manjunath
Sourcetree Mac Developer 

I have now used the beta for two weeks and I have not yet encountered this error anymore. 

So the fix you've implemented works for me :)

Also I did not get any 403 errors.

Thanks you're an awesome team&company!

Ana Retamal Atlassian Team May 23, 2018

So glad to hear that! Have a good day :)

Ana

0 votes
Manju Atlassian Team May 07, 2018

Please check the remote URL for the repository. It looks like your account is ssh while the remote URL is https. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you