Help : "Fatal: UriFormatException encountered." when trying to clone

My issue occurred when I tried to open my repo in SourceTree for the first time of the day (yesterday, everything was ok). It was impossible to open it (nothing happened when trying to). So I wanted to make a nice cleanup : I made a backup of my local repo, deleted the bookmark and tried to clone back the project.

As you can see in the title, I encountered a weird message : "Fatal: UriFormatException encountered." My URL is nothing special : https://myName@bitbucket.org/myTeam/myProject.git. Neither my name, my team or my project has any special characters : they all have only classical letters from 'a' to 'Z', no accent or whatever. I don't have any port in the URL either (when I googled the error message, I saw this could be a problem).

I tried to uninstall SourceTree and reinstall it, it did NOT work (still the same message). I tried to uninstall SourceTree and reinstall previous version, it did NOT work. I tried to clone the same project from my account but on my teammate's computer, and it DID work. But still, I can't have it on my computer, which is an issue.

I don't really know what to do next... Is there a way to fully uninstall SourceTree on my computer and delete all references ? I just made an uninstall from Control Panel but I don't know if it's enough.

Or is there any other solution ?

Thanks in advance

2 answers

0 vote

Hi Léa, can you try uninstalling SourceTree following these steps:

  1. Wipe SourceTree preferences
  2. Uninstall SourceTree.
  3. Backup then delete the directory below before proceeding with next step
    • Navigate to C:\Users\<UserName>\AppData\Local and delete SourceTree & SourceTree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all SourceTree Files/Folder.
  4. Download the latest SourceTree and install it. 

Let us know if this helped!

Cheers,

Ana

Thank you for your advice but unfortunately it didn't work.

Hi, I'm Léa's teammate and I can confirm. We tried it twice, and we still have the same issue. Can we send you a log or anything to help you ?

If we don't have a solution quickly, I guess we're gonna need to format the computer...

Thanks for your help though.

Cheers.

Hi, I have the same issue. Were you able to solve it?

Unfortunately, the only way we could solve this was to actually format the computer and reinstall Windows. It worked, but as you can imagine, it has a few disadvantages...

Good luck with that !

Jeez, that's crazy. Ok, thanks for your your response!

Guys, I hate to tell you this, but I think it wise to inform the thread.  It appears that this was purely a Git problem, not a windows one:  

https://superuser.com/questions/1114193/when-cloning-on-with-git-bash-on-windows-getting-fatal-uriformatexception-enco

Of course this link is to a post that was created over 11 months before this one.  I can only speculate that this may have been a Git version interaction bug.  If I'm right, it appears that github upgraded their Git server version the morning of July 20th to an incompatible version of Git that you had either installed before or with Source Tree.

Probably the only reason that Windows formatting fix worked was because after you finished, you went to the Git website and downloaded the latest version of Git, which happened to be compatible with the version github was using.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you