Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,474
Community Members
 
Community Events
176
Community Groups

Failed to list teams for the user(username).The endpoint has been removed.

Seeing the error message on account name:

Failed to list teams for user[username].

The endpoint has been removed . See our documentation for more information.

https://devloper.atlassian.com/cloud/bitbucket/rest/api-group-teams/#api-teams-get

 

3 answers

We've started to switch to Github.

0 votes

Consider visiting Sourcetree Beta Program . There is a latest version release for the Mac OS for SourceTree.

If you still find any issues, Please raise a bug in the below link:

Report a Bug!

Thanks,

I've tried the Sourcetree Beta app, but it's not working either. Reported a bug.

Like unnanego likes this
0 votes
Vipin Yadav Atlassian Team Jan 26, 2022

Yes. We are aware of this issue and it has been fixed and will be released in next Sourcetree release of 3.4.8.

 

Thanks,

Thank you!!
When can we expect the next release to happen?

Like ralla likes this
Vipin Yadav Atlassian Team Jan 27, 2022

Beta version is supposed to release after 2 weeks. 

Like SMahadasu likes this

But it worked two days ago! So now sourcetree is useless for another two weeks?!

What about the macOS version? It doesn’t work either. (Nor does the Bitbucket integration in Xcode 13.2.1.)

+1, not working on MacOs version 4.5.1.

Same problem here on the latest mac version. I'm very surprised about this happened to such a professional team. Please release the fix soon. Thanks.

Today is exactly two weeks, any news? 

We are still working on the issue. Will keep the community posted on the release of the fix.

Thanks!

This issue is affecting my team as well, with team members unable to access organisations remote repositories.  awaiting v3.4.8 for the fix.

Vipin Yadav Atlassian Team Feb 21, 2022

Hi,

We have released beta of Windows Sourcetree 3.4.8 today and you can download this from below link. 
SourceTreeSetup-3.4.8-beta-1  and let us know if it is working fine.

Thanks,

Vipin

Hi Vipin, any news about the MacOs version of the app?

Hi Vipin, Thanks for the update. I have downloaded the new beta version Windows Sourcetree 3.4.8. 
I have seen the error gone on my username but the sync is not happening with my local workspace . If I am checkingout some branch in Sourcetree, its not getting reflected into my local workspace(in my case Eclipse). Even if I modify some code in my workspace, its not being shown as uncommitted changes.

Vipin Yadav Atlassian Team Feb 22, 2022

Hi @SMahadasu ,

We will check these things on our side too but it would be helpful if you can send us your log flie from %localappdata%\Atlassian\Sourcetree\sourcetree.log and record a small video of your issues and can attach that will be nice for us to investigate the issue.

Thanks,

Vipin

Vipin Yadav Atlassian Team Feb 22, 2022

Hi @wiljeonline-jeroen , 

 

we are still working on the mac release and we will keep you posted once the mac version is also released. 
Thanks,

Any update for mac? 

what the f is going on

Hi Vipin

One of the team members facing same issue, so checked the LOG file - can you take a look and advise please 

log file sourcetree.log shows as below:

2022-03-16T09:31:34: LogHost: Initializing to normal mode
ERROR [2022-03-16 09:32:42,586] [1] [SourceTree.Notifications.NotificationsManager] [Log] - Unable to set owner as parent is not visible or non-existent
ERROR [2022-03-16 09:32:51,098] [11] [SourceTree.Analytics.Emau.EMauSubmissionService] [Log] - Unable to generate batch, return null
System.NotSupportedException: This type of CollectionView does not support changes to its SourceCollection from a thread different from the Dispatcher thread.
at System.Windows.Data.CollectionView.OnCollectionChanged(Object sender, NotifyCollectionChangedEventArgs args)
at System.Collections.ObjectModel.ReadOnlyObservableCollection`1.OnCollectionChanged(NotifyCollectionChangedEventArgs args)
at System.Collections.ObjectModel.ObservableCollection`1.OnCollectionChanged(NotifyCollectionChangedEventArgs e)
at System.Collections.ObjectModel.ObservableCollection`1.ClearItems()
at DynamicData.ListEx.Clone[T](IList`1 source, Change`1 item, IEqualityComparer`1 equalityComparer) in d:\a\1\s\src\DynamicData\List\ListEx.cs:line 112
at DynamicData.ListEx.Clone[T](IList`1 source, IChangeSet`1 changes, IEqualityComparer`1 equalityComparer) in d:\a\1\s\src\DynamicData\List\ListEx.cs:line 76
at DynamicData.Binding.ObservableCollectionAdaptor`1.Adapt(IChangeSet`1 changes) in d:\a\1\s\src\DynamicData\Binding\ObservableCollectionAdaptor.cs:line 56
at DynamicData.ObservableListEx.<>c__DisplayClass21_0`1.<Adapt>b__1(IChangeSet`1 changes) in d:\a\1\s\src\DynamicData\List\ObservableListEx.cs:line 586
at System.Reactive.Linq.ObservableImpl.Select`2.Selector._.OnNext(TSource value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Linq\Observable\Select.cs:line 39
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Reactive.Stubs.<>c.<.cctor>b__2_1(Exception ex) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Internal\Stubs.cs:line 16
at System.Reactive.ObserverBase`1.OnError(Exception error) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\ObserverBase.cs:line 61
at System.Reactive.AutoDetachObserver`1.OnErrorCore(Exception exception) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Internal\AutoDetachObserver.cs:line 77
at System.Reactive.ObserverBase`1.OnError(Exception error) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\ObserverBase.cs:line 61
at System.Reactive.Sink`1.ForwardOnError(Exception error) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Internal\Sink.cs:line 61
at System.Reactive.Linq.ObservableImpl.Select`2.Selector._.OnNext(TSource value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Linq\Observable\Select.cs:line 41
at System.Reactive.Concurrency.Synchronize`1._.OnNext(TSource value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Concurrency\Synchronization.Synchronize.cs:line 42
at System.Reactive.AutoDetachObserver`1.OnNextCore(T value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Internal\AutoDetachObserver.cs:line 62
at System.Reactive.ObserverBase`1.OnNext(T value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\ObserverBase.cs:line 36
at System.Reactive.Subjects.Subject`1.OnNext(T value) in D:\a\1\s\Rx.NET\Source\src\System.Reactive\Subjects\Subject.cs:line 148
at DynamicData.SourceList`1.InvokeNext(IChangeSet`1 changes) in d:\a\1\s\src\DynamicData\List\SourceList.cs:line 120
at DynamicData.SourceList`1.Edit(Action`1 updateAction) in d:\a\1\s\src\DynamicData\List\SourceList.cs:line 93
at SourceTree.ViewModel.Hosted.HostedProjectsViewModel.AccountManager_OnAccountsUpdated(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at SourceTree.Accounts.AccountManager.RemoveHostedAccount(IAccount account)
at SourceTree.Accounts.AccountManager.ReplaceHostedAccount(IAccount oldAccount, IAccount newAccount)
at SourceTree.Analytics.BaseAnalyticsService.get_UserId()
at SourceTree.Analytics.Emau.EMauSubmissionService.GetAasBatch()

Vipin Yadav Atlassian Team Mar 16, 2022

It looks like Sourcetree is missing some permissions. Could you please check that nothing is blocked for Sourcetree.

Still not working in Mac OSX v  4.1.8 ?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events