It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error: remote: Empty password in SourceTree

I had to install a new hard drive and trying to set all my software up again.

I kept getting an error about my bitbucket pw URL being empty in SourceTree, I noticed there was a red X next to my username in SourceTree, so I deleted and added my account again in SourceTree. It seemed to go through fine, no more red x, but now getting this error when I try to clone any reposit, Don't understand why it keeps saying authentication is failing when it seems fine on the bitbucket website and when I add the account to SourceTree.

 

Note: I removed personal info.

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false ls-remote https://[username]@bitbucket.org/site_team/site.git
Output:
Error: remote: Empty password
fatal: Authentication failed for 'https://[username]@@bitbucket.org/site_team/site.git/

 

3 answers

0 votes
Ana Retamal Atlassian Team Mar 30, 2018

Hi Kaira! I've seen that there's a typo in one of the lines, I was wondering if this was only caused when you pasted the error here, or if it's actually mistyped in your configuration:

https://[username]@@bitbucket.org/site_team/site.git/

If so, can you confirm that you connected your account following the steps at Connect your bitbucket account.

Apart from that, can you try performing the same operation using the command line so we can see if it's an error with the authentication or an error in Sourcetree?

Let us know!

Ana

 That typo was mine. I just didn’t want to use my private domaine information and username. 

 I did follow those steps and connection and authorize Asian seemed fine but it’s not cloning.  The only other thing I can think of is when I transferred my software over to the new hard drive I did include the local app data.  Maybe there’s a conflict?  Doing that allowed source tree to recognize my repositories though I think 

Having exactly the same problem:

 

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://me_here@bitbucket.org/team/repo.git
Output:
Error: Logon failed, use ctrl+c to cancel basic credential prompt.
remote: Empty password
fatal: Authentication failed for 'https://me_here@bitbucket.org/team/repo.git/'

 

Does someone know how to fix this? And i don't mean sending us to a basic manual with old screenshots that are not what you see in the current version.

I need to add that I tried to uninstall SOURCETREE and it WOULDN'T UNINSTALL! It disappeared from the Uninstall Programs dialog immediately but NOTHING WAS UNINSTALLED!!

I deleted all local data, and then reinstalled. There were some install glitches, but, in the end, it all worked out.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,942 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you