Error en pull:

Al tratar de hacer Pull sobre todos mis proyectos me da varios errores:

 

Primero,

remote: Too many invalid password attempts. Try logging in through the website with your password

 

Después,

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

 

He cambiado la contraseña en mi cuenta de atalasian y he vuelto a entrar a bitbucket, indicando a mano el correo y la nueva password (sin hacer login de google como recomiendan en los foros).

 

1 answer

This widget could not be displayed.

Hola Belen! First of all please note that we can only provide support in English :)

There's a thread created by another member of the Community where some users shared the solutions that worked for them regarding this issue. There are a few available options, I've listed them here for you. You can find the post at Authentication issues:

  • Delete the Windows Credentials stored in Windows (that's where SourceTree stored them), delete the passwd file, then restart SourceTree. To see and remove them, do the following:
    • 1. Open the Control Panel and click on User Accounts.
    • 2. In the left hand list of links, click Manage Your Credentials. When it opens, it shows your Web Credentials.
    • 3. Click the Windows Credentials "button". This shows your stored Windows credentials. Look for entries that start with "git:http" and include your server name and/or user name and remove them.
  • Go to Repository > Repository Settings, select your repository, and change the username from your Bitbucket username to your Atlassian account's email address. Then, remove the passwd file.
  • Download SourceTree version 2.1.2.5 from our website and install it. Reject the upgrade to 2.1.10 that comes up.
  • Update embedded git from 2.10.2 to 2.13.2

I hope this helps you! If none of the above works for you, please let us know if you're using Windows or Mac and if you get the same error when you perform these operations from the command line.

Cheers,

Ana

Hi,

 
I've tried some of those steps, but they didn't work. And I wasn't able to download the 2.1.2.5 version, your link downloads 2.1.10. 
 
I'm using windows, and I had never run the operations from the command line, always from sourcetree. 

It seems I have solved it by myself. I uninstall v 2.1.10 and reinstal an old 2.0.20.1 that I had in the donwload folder. 

With that change, I have been able to push my changes and we can see them on the bitbucket web page of the project. 

Thanks for letting us know, Belen! I contacted the developers regarding this issue, as it seems there are more users experiencing the same problem. In the meantime, using an older version is a valid workaround.

Cheers!

Ana

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

880 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you