Does SourceTree 1.5.4 on a Mac work with System Mercurial version 2.3.1?

I'm using SourceTree 1.5.4 on a Mac PowerBook Pro 10.7.5, and have it set to use System Mercurial which is version 2.3.1. When I try to create a new repository I get the following messages:

hg init -y /Users/sshantz/myrepo

abort: No module named repo!

Completed with errors, see above

If I reset to the embedded Mercurial I can create a new repo without any problem. Does SourceTree support using Mercurial 2.3.1?

Thanks, Steve

1 answer

1 accepted

I hadn't tried hg 2.3 yet, but I just did so and it appears they've made another breaking change to the module structure which breaks the hgsubversion extension. Very annoying when they do this!

For the moment, the workaround is to either use the embedded hg 2.2.x, or disable the hgsubversion extension in Preferences > Mercurial (uncheck the box next to hgsubversion). Either way worked for me, but obviously with the latter approach you won't be able to interact with Subversion servers.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

794 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you