Disappointment...

This is not so much a question, as a statement: I like Atlassian products and gave SourceTree a try today (fresh download, Windows 7). I use it to access a Stash repository over https or browse a local repository (remote is also accessed via https).

Problems I ran across:

  • Terminal button does not open a terminal
  • Fetch does not work (apparently it does not realize that it needs a password)
  • Browse hosted repos: takes ages to realize that it does not have the correct credentials, but gives me no way to enter them
  • Out of curiosity tried "Interactive rebase". Got error message: command "C:\Program Files (x86)\Atlassian\SourceTree\stree_gri" not found, but the file is exactly in this location
  • Got it to accept my credentials for Stash, but a following CLONE never finished.
  • Although I instruct it to save and remember my credentials, after a restart the credentials are gone.
  • After cancelling fetch & clone commands, orphaned git, git-remote-https and other processes remain there forever
  • ...

I'm unaware of any problems or special features my PC setup could cause - just a stock Win7 inside a company domain, git works from commandline etc. I did not expect these kind of problems with SourceTree. Quite a disappointment. I'm giving up on it.

4 answers

1 accepted

This widget could not be displayed.

Sounds like you may have some environment variables that are incompatible. The path for the "not found" command probably requires ".exe" on the end.

Also check to make sure your GIT_SSH environment variable points to a valid executable. SourceTree should come with a plink.exe file that should do the trick.

This widget could not be displayed.

Sorry to hear that. I don't have any (serious) problems with SourceTree and it totally replaced TortoiseGit for me.

This widget could not be displayed.

Seth, thanks for the hint. You are right: it was an environment variable problem: SourceTree was confused by my Cygwin installation (and the paths and variables set there.) Now SourceTree is working as advertized smile

It would've saved me some hours, if SourceTree gave me some kind of hint about its problems. All I got was cryptic error messages...

Thanks again!

This widget could not be displayed.

since I'm experiencing the same problems, and also have cygwin installed, can you possibly write what should I look for in the environment variables ? 

I'm unable to give you detailed advice: I switched computer's in the mean time and have another setup now. As far as I recall, you should check the global path settings on your machine: if Cygwin is before your "regular" Windows git executable, then this causes problems. You could also try e.g. starting SourceTree from within a console which has a "clean" environment which has no reference to Cygwin.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

874 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you