Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Connection to GITHUB stopped working

Deleted user Feb 23, 2018

I've been using SourceTree 2.4.8 on Windows 10.

I had a personal access token created on my GITHub and was using that to authenticate.

Yesterday, SourceTree was working fine until about 2pm PST when suddenly it started giving me this error:

=============

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch orgin
fatal: HttpRequestException encountered.
An error occurred while sending the request.

remote: Repository not found.
fatal: repository 'https://github.com/{my repo}' not found

Completed with errors, see above.

=============

No one changed anything, that I can tell. I figured it was an authentication issue. So I have refreshed my PAT (Personal Access Token) and reset my credentials. Whenever I try to fetch, it comes up with a GITHub login screen, I enter my username and the PAT as the password, then it fails and give me that same error. Our GITHub uses SSO if that makes a difference.

I've googled and tried so many things. 

I reinstalled source tree.

I cleared stored credentials from the Credential Manager.

I have not tried an SSH key, I would prefer not to use one if i can.

Desperately need help.

 

1 answer

The problem is that SourceTree's embedded Git client comes with git-credential-manager v1.12, which no longer works with Github since they disabled TLS 1.1 on their site.  You need to get git-credential-manager v1.14.  Easiest way to do that is to install a current copy of the Git client separately, and then switch SourceTree over to use that ("system git") instead of its embedded client.  Alternatively, you can update git-credential-manager in your embedded client by replacing its files with the newest version from Microsoft.

(This text here because this site doesn't allow me to post the same message in multiple threads, even when it's the answer to all of them.)

Deleted user Feb 26, 2018

Thanks Andrew. I managed to fix the problem, but not sure if your solution would have been better than what I did. 

Apparently when you uninstall SourceTree using Add/Remove programs it barely removes the program. So I then nuked the folder where SourceTree was installed.  I then installed the latest GIT on my machine. Then reinstalled the latest source tree.  Then I deleted my local copies of my repos and checked them out from origin with SourceTree.

When logging in I use my Github username and my PAT as my password.  

Everything appears to be working fine again.  I think by installing GIT I may have inadvertently done what you are suggesting as my SourceTree is using my system GIT.

 

Thanks again for the response. 

Thank you Andrew!
Finally someone who broke it down :)

I changed Source Tree's git to system and it worked right away.

Now I installed the credential manager v1.14 from MS but it didnt work but I'll see if that changed after a restart, and if not I'll stick with the system git.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,733 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you