Commit template message

Hello,

 

I am trying to create a template commit message in sourcetree, but no success. I have already tried with git config --global commit.template and to use prepare-commit-msg hook and it worked in both cases from the command line, but not in sourcetree. I have made research on internet and it seems that a lot of people have this problem. Is there any other solution or is a missing feature/limitation? 

I am using SourceTree 1.6.21.0 on Windows 7.

2 answers

I've never tried, but I'd guess it is a missing feature. If you don't get a helpful answer, submit a feature request to jira.atlassian.com, and put a link here as an answer so others can find it.

Actually it seems to be a broken feature (at least support for commit.template) as it was already implemented 2 years ago:

https://jira.atlassian.com/browse/SRCTREE-982

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

841 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you