Commit keyboard shortcut opening the OS X color palette?

Recently... when I use the keyboard shortcut in SourceTree to commit changes within (cmd-shift-c), Mac OS X's system-wide color palette opens up.  Using the "diamond ring" toolbar icon still works, as does the menu option Repository > Commit....

It's not every time, but probably 60-70% of the time I'd say.  Maybe there's some conflict with another running Mac App.  I dunno.

As I'm typing this, I shut down all my apps (except Chrome, and SourceTree) and used the key command again.  Boom – worked.  I should have taken note and tried it after shutting down each app.

Guess I'll wait for it to happen again, and shut them down one-by-one until I find the culprit.

 

 

Screen Shot 2016-03-30 at 1.08.30 PM.png

2 answers

1 accepted

After all this time, I FINALLY figured it out today.  It was the Sip color picker app:

http://sipapp.io/http://sipapp.io/

I guess I would use it once or twice and forget that it's running since it's this tiny little thing in the menu bar, and not a full-blown app running in my dock.  At any rate... redemption, finally.

smile

 

 

I've been doing more testing... and I now think this clearly is not SourceTree's fault.  It happened again today... I shut down all my apps and just happened to be in the finder and hit cmd-shift-C again... there it was.  The friggin' color palette.  In the Finder, that should bring up the "Computer" folder.

So... some app that I have must enable that shortcut, and then not release it properly when I'm not using it.  :-/ 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

430 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you