Change Logininfo

Hi,

in SourceTree I want to create a new project.
In the first time I say "save password" and I have made it to create a "link" to a new project. Later I get some problems, so I tryed "git pull" manually. It doesn't work, so I try to change my password. Now "git pull" asks for a password and worked, but in SourceTree there is the error "Access denied" when pulling.

When I try manually use the command
"git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=manager-st fetch origin" in the git bash it asks for the password and it worked.

I think there is the old password saved anywhere, but I don't find a way to delete this reference and get the login-window again to reset the password.

Sorry for my english and I hope you understand what I'm asking for.

Greetings from Germany
 Gerit Freericks

4 answers

1 accepted

For further help:

I solved this, by the following way:
1) Uninstall SourceTree
2) Delete/Rename "C:\Users\<<User>>\AppData\Local\Atlassian"
3) Install SourceTree
this way it asked for a password and since then it worked.

Nevertheless thanks for trying! There is nothing worse feeling alone!

Greetings from Germany
 Gerit Freericks

What version of SourceTreeare you using and on what OS?

SourceTree is 2.1.2.5.

Using on Windows 10 Pro x64.

Greetings
  Gerit Freericks

0 votes

Hi Gerit

SourceTree stores its credentials in Windows Vault.

If you use the Win-Key and search for Windows Credential Manager you will find the entries prefixed with 'git:' You can delete the entries there.

I've deleted it there, thanks for the info, I don't know that.

But I've made something wrong, it doesn't work.
At start, when I try to make a new connection with "clone"
I use
"ssh://<<user>>@<<ip>>/var/git/<<project>>/"
for it and SourceTree says "This is not a valid source path / url".
so I tried:
"ssh://<<user>>@<<ip>>/var/git/<<project>>"
but I got the same message. In "details" I can read "Access denied", but this message comes alwaly. Even when I delete the entries in the Windows Credentials Manager.
Any Ideas left?

Greetings
 Gerit Freericks

0 votes
Mike Corsaro Atlassian Team Jul 19, 2017

Hello! You can change the passwords for your accounts in the "Authentication" tab in the "Options" menu. In that tab, you should see the account that you're using (either under "Accounts" or "Saved Passwords"). Select the account, and select "Edit". You should be able to change the password there.

I've tried this earlier, but sometimes the entries stayed there after "delete".

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

241 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot