Cannot re-install SourceTree

I tried to remove source tree because it was extremely slow.  I think in order to copy files onto my dev environment, I actually checked them out causing it to be slow.

None the less, now I cannot reinstall.  It keeps saying there is a newer version installed and will not install.

I rebooted in safe mode and searched for files and removed them all, but still cannot install.

The set up wizard says "SourceTree setup ended prematurely because of an error.  Your system has not been modified.  To install this program at a later time, please run the installation again.  Click the Finish button to exit the Setup Wizard."

Any ideas?

Thanks,

Sunny

5 answers

1 accepted

This widget could not be displayed.

In Windows, removing files is rarely a safe way to uninstall a program. Installers will often register the application other places in the OS (like the registry). The sourcetree installer may be checking that, and trying to enter some sort of update mode, which fails when it can't find files.

I don't think I can help much here besides identifying the problem. Maybe SourceTree still shows up in the add/remove programs dialog?

This widget could not be displayed.

How did you remove SourceTree? What OS are you using?

This widget could not be displayed.

OS is windows 8, I did an uninstall, and an reinstall and it was still very slow. So then I started in safe mode and did a search on all source tree files and removed them, Now I can no longer do an install.

This widget could not be displayed.

Hi Seth, That worked. I had done an uninstall, but then in retrying, I guess it had placed itself back in there. I uninstalled from control panel and was able to do a fresh install. Thanks bunches. Sunny

This widget could not be displayed.

In many cases, the problem is with MSI registry - corrupted reg.

Here is the only tool can fix corrupted MSI registry: https://support.microsoft.com/en-gb/mats/program_install_and_uninstall/en

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

868 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you