Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot download SourceTree 2.7.3a on the Apple Mac

macOS 10.13.6

Hello, I'm trying to download SourceTree 2.7.3a on the Apple Mac but my download keeps failing. I've tried about 4 times now. I also tried downloading an earlier version but same result.

I've recently downloaded about 1.5 GB of Audio stuff from a variety of sites, so I'm reasonably sure that the problem is not at my end!

Does anyone have any idea what the problem could be, or is there an alternative URL for downloading? Thanks!

 

 

 

1 answer

1 accepted

0 votes
Answer accepted
Manju Atlassian Team Jun 25, 2018

You should be able to download it from here

However, I recommend you to use the latest version 2.7.6 which has fixes for git and mercurial vulnerabilities. It can be downloaded from here 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,262 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you