Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can add bitbucket account to source tree but cannot clone repository using same credentials.

Edited

Hello,

 

I can successfully add my bitbucket account to sourcetree using a username and password. However, when I try to clone a repo in the account I get a login prompt for bitbucket. When I use the same username and password that was used to add the account I get an invalid username/password exception.

 

I have tried changing my password with the same result. Anyone else experienced or have insight on this issue?

 

Thanks!

2 answers

1 accepted

0 votes
Answer accepted

When I downgraded to a further back release, I was able to successfully clone my repo. I have since tried the last to latest version, 2.6.9 and I am still able to clone. However, when I try the newest version, 2.6.10 I get that issue.

0 votes
Ana Retamal Atlassian Team Aug 31, 2018

Hi John, welcome to the Community!

We'll need more information to help you solve this issue:

  1. Are you trying to clone a repository that belongs to your account?
  2. Do you have the right permissions to access that repo?
  3. When you try to enter your credentials, are you trying to connect to an individual account or to a team account?
  4. Are you using Windows or Mac? If Windows, please make sure Internet Explorer is updated to the latest version as Sourcetree relies on it for the authentication steps.
  5. If you try logging in from the web UI, do you get any error?

Let us know!

Ana

Hello,

1. Yes, the repo belongs to my account

2. Yes I have full permissions to the repo.

3. I am not sure, I believe it is an individual account where I have given permissions to the repo to a collegue.

4. I am using windows and IE is up to date.

5. I can successfully log in from the web ui

 

Please see my answer as I have since resolved this issue.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,692 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you