Bug - GitHub Authentication Failure v1.6.24

Earlier today I updated SourceTree to version 1.6.24 and it is now failing to authenticate with GitHub - it always reports invalid username/password even when I know they are correct.

We are not using 2-factor authentication so that isn't the problem.

One of my colleagues confirms that 1.6.23 worked fine for them but upgrading to 1.6.24 also stopped them from authenticating with the same error.

When will this be fixed?

EDIT: Experimentation shows that it still works via the terminal, just not when performing the actions using Sourcetree.

7 answers

This seems to be an issue with SrcTreeWin 1.6.24

See:https://jira.atlassian.com/browse/SRCTREEWIN-3957

 

Workaround: Downgrade to older SrcTreeWin version ...

Same problem for me, but authenticating to a repo on Stash. Same credentials work on the command-line, and in the web interface. Have tried both embedded and system version of Git - same repetitive login dialog.

What's interesting is after trying a few times, I get a different message saying I need to enter a Captcha, so it's sending something to the server, just not the credentials I am supplying.

Could use a quick fix / workaround please (I guess I'll be using command-line only for now).

 

Same here. Any workaround?

Hmmm ... isn't my suggestion to downgrade a workaround?

I also was hit with this bug. Uninstall Sourcetree. Reinstall. This version seems to work for me. http://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.6.22.exe

same here downgrade worked

Same problem here but with Assembla's hosted GIT.

Looks like this has been fixed as of v1.6.25. No need to downgrade any more smile

Thanks for the update that this is fixed. 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

799 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you