Beyond Compare external merge tool won't start

Hi

The external diff works but the external merge does not. Below are my global .gitconfig settings. It worked once, but after that it stopped. When I select "Resolve Conflicts" -> "Launch External Merge Tool" I get a popup saying "Visual Merge in Progress" with Filename and Repository listed and a button to select "Abort".

I also tried updating to the latest 1.6.21 version.

[difftool "sourcetree"]
cmd = 'D:/Program Files (x86)/Beyond Compare 4/BComp.exe' \"$LOCAL\" \"$REMOTE\"
[mergetool "sourcetree"]
cmd = 'D:/Program Files (x86)/Beyond Compare 4/BComp.exe' \"$LOCAL\" \"$REMOTE\" \"$BASE\" \"$MERGED\"
trustExitCode = true
[core]
excludesfile = C:\\Users\\epatto.SONOSITE\\Documents\\gitignore_global.txt
autocrlf = true
[http]
[push]
default = current

I also tried using "Resolve Using Theirs" and the popup says "Could not update one or more files, please check that no other application is locking your files". Then I started process explorer and it said no process is locking the file.

Then I noticed that the same file was in SourceTrees "Unstaged Files" list. I'm learning git. Why would the file be in the staged and unstaged area? When I clicked on the file in the unstaged area, it disappeared from both the staged and unstaged windows. Strange.

Many thanks for your help

Cheers

Eddie

1 answer

You might have a look here - Atlassian has verified this as an error in current sourcetree

I have the same problem - what I know yet: I'm running git 2.5.2 on windows7. git uses several .gitconfig files: systemwide, global and per repository. If the settings you mentioned above are within systemwide or global .gitconfig, launching the external diff- or merge-tool fails - but if those settings are within the config-file of the repository (within the .git folder) it works: at least that's the solution which works here ...

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

710 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you