It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Authentication Failed with bitbucket server

SourceTree version 2.1.11.0 is unable to authenticate to bitbucket server after changing my Active Directory password.

So far I have tried solving the capthca, removing vault entry, accounts.Json file and passwd file but nothing seems to be working.

Following is from sourcetree.log file

ERROR [2017-09-08 14:15:30,127] [13] [SourceTree.ViewModel.CloneNewDialogViewModel+<CheckSource>d__197] [MoveNext] - Could not determine repository from: [server url], output was:
ERROR [2017-09-08 14:15:30,127] [13] [SourceTree.ViewModel.CloneNewDialogViewModel+<CheckSource>d__197] [MoveNext] - fatal: remote error: CAPTCHA required
Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

Visit Bitbucket at [server Url] for more details.

ERROR [2017-09-08 14:18:48,844] [30] [SourceTree.Exceptions.RemoteHostException] [.ctor] - Insufficient authentication credentials
ERROR [2017-09-08 14:18:48,892] [1] [SourceTree.Exceptions.RemoteHostException] [.ctor] - Failed to check login for user [User Name]

1 answer

0 votes
Ana Retamal Atlassian Team Sep 11, 2017

Hi Tewodros, I'm assuming you're able to access Bitbucket Server normally, just not able to connect SourceTree. 

SourceTree for Windows uses the Git Credential Manager (GCM) to store credentials, can you check in there to make sure there are no remnants from the old credentials?

Also I would try wiping SourceTree preferences and, if none of the above works, a clean install of SourceTree:

  1. Wipe SourceTree preferences (if you didn't before)
  2. Uninstall SourceTree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step
    • Navigate to C:\Users\<UserName>\AppData\Local and delete SourceTree & SourceTree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all SourceTree Files/Folder.
  4. Install SourceTree. The latest version can be downloaded from our website.

Let us know how it goes!

Regards,

Ana

I updated to the latest version of SourceTree version 2.3.1.0 which resolved the issue I was seeing last week. Hopefully, I won't see any issues in the future when changing my AD password.

Hello @Ana Retamal 

It worked for us some days and it appeared again even after the above mentioned workaround. Our current version of Sourcetree is 3.0.15. Is there any way we can get rid of this issue permanently.

Regards,

Bhakti Prasad Panda

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,989 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you