After updating, sourcetree repository type not valid

I recently updated my SourceTree on Windows and was getting an error that the path was invalid. I tried to clone the repository again and when I directed to the Bitbucket path

Repository Type: This is not a valid source path / URL

When I click Details...

 System.ComponentModel.Win32Exception: The system cannot find the specified
hg: parse error at C:\Users\XXXX\AppData\Local\Atlassian\SourceTree\hgrc_sourcetree:1:

remote: Not Found

fatal: respository 'https://xxxxxxxx@bitbucket.org/xxx/xxx/' not found


 – The xx's are blocked out, but they are properly linked.

I'm unsure what happened. Can anyone help?

1 answer

I've also updated both Git and Mercurial under Tools > Options 

The file paths are different than the one above for the ignore files... Does this have anything to do with it?

Is it possible for me to start from scratch? Uninstall and reinstall Sourcetree? Would that mess anything up?

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

273 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot