Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

古いSourcetreeでクローンできない

お世話になっております。

 

先日最新版Sourcetreeが起動しなかったため、

バージョン1.7.0.32509でインストールを行いました。

起動自体は問題なく完了し、後はクローンを行うだけだったのですが、

そのときにエラーが発生しクローンができません。

 

ネットで調べた結果PuTTYのVersionが古いためだということがわかりましたが

肝心のPuTTYの設定はどこから行えばいいのかわかりません。

 

一体どこに新しいバージョンのPuTTYをインストールし、

Sourcetree上から起動できるようにすればいいのでしょうか。

また、その場合のPuTTYは64bitにすればいいのでしょうか。

 

下記にエラー文を記述しておきます。

git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive git@github.com:AkikanAlumiloid/AutoReRetweet.git C:\Users\<user_name>\Documents\AutoReRetweetProj
Cloning into 'C:\Users\<user_name>\Documents\AutoReRetweetProj'...

warning: templates not found C:\Users\<user_name>\AppData\Local\Atlassian\SourceTree\git_local\share\git-core\templates

FATAL ERROR: Couldn't agree a key exchange algorithm (available: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521)

fatal: Could not read from remote repository.

2 answers

1 accepted

1 vote
Answer accepted

こんにちは、アトラシアンの山本です。

本件は SRCTREEWIN-7505 に該当します。コメント欄では v1.7.0 の利用者も問題に遭遇しているとの報告があります。すでにご認識の通りPuTTYを更新すると解決したそうですので、下記にて回避策を要約してみます。

 

  • パス "C:\Program Files (x86)\Atlassian\SourceTree\tools\putty" を最新版に置き換えた
  • インストール先が "Program Files (x86)" なので32bit版が該当すると考えられる

 

なお、PuTTYの現時点での最新版は 0.70 です。

こんにちは

 

要約してくださりありがとうございます。

パスに存在したPuTTYを最新版に置き換えたところ、

問題なくクローンが出来ました。

 

本当にありがとうございます。

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,262 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you