Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,065
Community Members
 
Community Events
168
Community Groups

Git server password issue - Sourcetree 2.0.19.1 on Windows 10

After an update to 2.0.19.1 my git server keeps responding wth authentication failure.

Upon going to Tools->Authetication no accounts were listed - normally I would delete the stored password associated with the account and then get prompted for the password on the next fetch - this did not happen like before.

I ended up deleting the passwords file in %localappdata%\Atlassian\SourceTree\ and upon restarting the app and doing a fetch I was prompted again.

Maybe someone else has had a similar experience?

Kind regards

3 comments

Under Windows 10, using the same sourcetree version I also receive literally dozens of auth prompts within just about one minute.

They say "git credentials manager for windows", but they actually point to one of my mercurial repositories.

Ana Retamal Atlassian Team May 04, 2017

Hi Jaques, are you using Git Credential Manager for Windows? There are some other users having problems with it, and there're are some suggested solutions at https://community.atlassian.com/t5/SourceTree-questions/Git-Credential-Manager-for-Windows-Popups/qaq-p/579905/comment-id/14168#M14168.

Are you being constantly asked to enter a password as well? In that case that was identified as a bug that our developers are already working on fixing. You can download the version 2.5.1 (public alpha) which has additional improvements for authentication. See if that fixes your issue and let us know!

Hope this helps :)

Ana

Hi Ana, thanks for your reply.
Unfortunately I'm not sure if Git Credential Manager is being used. My setup is that I have is Win10 with Git scm installed and afterward SourceTree installed.

I was not prompted for a password at all - hence the server response of Authentication Failure - too many login attempts.

However, I do want to mention that my issue was resolved by deleting the file as mentioned in my post - after that and restarting the app I was prompted for my password again, which was then accepted, and is now functioning normally.

Ana Retamal Atlassian Team May 08, 2017

I'm glad to hear that your issue was solved, Jaques, and thanks for sharing with the community :)

Have a nice day!

Ana

This issue is still happening in 2.3.1.0 version.

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events