"NoClassDefFoundError" exception using the atlas-version command

Hi everyone, I am a newbie in atlassian JIRA and I would like to create my first plugin for it. While following the instructions of the tutorial, as for setting up the SDK prerequisites on a Windows System, I was in the following step (Installation of Atlassian SDK). After an installation of the SDK and restarting the computer, I used the "atlas-version" command. The result is pasted below: ======================================================================== ATLAS Version: 4.2.3 ATLAS Home: C:\Users\Omar.Khaldi\atlassian-plugin-sdk ATLAS Scripts: C:\Users\Omar.Khaldi\atlassian-plugin-sdk\bin ATLAS Maven Home: C:\Users\Omar.Khaldi\atlassian-plugin-sdk\apache-maven -------- Executing: "C:\Users\Omar.Khaldi\atlassian-plugin-sdk\apache-maven\bin\mvn.bat" --version -gs C:\Users\Omar.Khaldi\atlassian-plugin-sdk\apache-maven/conf/settin gs.xml Exception in thread "main" java.lang.NoClassDefFoundError: org/codehaus/classwor lds/Launcher Caused by: java.lang.ClassNotFoundException: org.codehaus.classworlds.Launcher at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) Could not find the main class: org.codehaus.classworlds.Launcher. Program will exit. ======================================================================== Can someone help me or give me a tip about what's going on. Here are some other information that can be useful: - I am actually using Windows 7 (64-bit) with Java 1.6. - I have already installed maven, the version is 3.0.5 Thanks in advance for your help, Omar.

2 answers

1 accepted

2 votes
Yilin Mo Atlassian Team Jun 30, 2013

You need to follow the procedure here to let SDK running on Maven 3


Short summary of the procedure in the URL above: set the environment variable ATLAS_MVN to the executable of mvn three. In my Windows installation:

set ATLAS_MVN=C:\apps\apache-maven-3.0.4\bin\mvn.bat

After this setting atlas-version worked as expected.

Thanks for your help Yilin MO, I found the solution just before to see your answer.

Here is it if someone will have the same problem in the future: I already had another version of Maven of my computer provided by the company, I think that it's getting confused with the 2 different versions. So I deleted Maven 3 and JIRA works without any problem.



Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published yesterday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

264 views 5 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot